summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/ksdssp/ksdssp-040728-r1.ebuild')
-rw-r--r--sci-chemistry/ksdssp/ksdssp-040728-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sci-chemistry/ksdssp/ksdssp-040728-r1.ebuild b/sci-chemistry/ksdssp/ksdssp-040728-r1.ebuild
new file mode 100644
index 000000000000..28b17cab3773
--- /dev/null
+++ b/sci-chemistry/ksdssp/ksdssp-040728-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ksdssp/ksdssp-040728-r1.ebuild,v 1.1 2012/10/18 16:30:03 jlec Exp $
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="An open source implementation of sci-chemistry/dssp"
+HOMEPAGE="http://www.cgl.ucsf.edu/Overview/software.html"
+SRC_URI="mirror://gentoo/${P}.shar"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="sci-libs/libpdb++"
+DEPEND="${RDEPEND}
+ app-arch/sharutils"
+
+S="${WORKDIR}"/${PN}
+
+src_unpack() {
+ "${EPREFIX}/usr/bin/unshar" "${DISTDIR}"/${A} || die
+}
+
+src_compile() {
+ emake \
+ CXX="$(tc-getCXX)" \
+ PDBINCDIR="${EPREFIX}/usr/include/libpdb++" \
+ BINDIR="${EPREFIX}/usr/bin" \
+ .TARGET="${PN}.csh" \
+ .CURDIR="${S}" \
+ CC="$(tc-getCXX)" \
+ LINKER="$(tc-getCXX)" \
+ OPT="${CXXFLAGS}" \
+ LFLAGS="${LDFLAGS}" \
+ ${PN} ${PN}.csh
+}
+
+src_install() {
+ dobin ${PN}{,.csh}
+ dodoc README
+ dohtml ${PN}.html
+ doman ${PN}.1
+}