summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/phaser/phaser-2.1.4.ebuild')
-rw-r--r--sci-chemistry/phaser/phaser-2.1.4.ebuild23
1 files changed, 8 insertions, 15 deletions
diff --git a/sci-chemistry/phaser/phaser-2.1.4.ebuild b/sci-chemistry/phaser/phaser-2.1.4.ebuild
index af46085a9b40..5ed5ffeb5f20 100644
--- a/sci-chemistry/phaser/phaser-2.1.4.ebuild
+++ b/sci-chemistry/phaser/phaser-2.1.4.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/phaser/phaser-2.1.4.ebuild,v 1.3 2012/02/05 01:54:57 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/phaser/phaser-2.1.4.ebuild,v 1.4 2014/01/06 09:24:09 jlec Exp $
-EAPI="3"
+EAPI=5
-PYTHON_DEPEND="2"
+PYTHON_COMPAT=( python{2_6,2_7} )
-inherit base flag-o-matic python toolchain-funcs
+inherit eutils flag-o-matic python-single-r1 toolchain-funcs
CCP4VER="6.1.13"
@@ -26,17 +26,10 @@ DEPEND="${RDEPEND}
S="${WORKDIR}"/ccp4-${CCP4VER}
-PATCHES=(
- "${FILESDIR}"/phaser-2.1.4-chmod.patch
- "${FILESDIR}"/phaser-2.1.4-ldflags.patch
- )
-
-pkg_setup() {
- python_set_active_version 2
-}
-
src_prepare() {
- base_src_prepare
+ epatch \
+ "${FILESDIR}"/phaser-2.1.4-chmod.patch \
+ "${FILESDIR}"/phaser-2.1.4-ldflags.patch
use openmp && append-flags -fopenmp