summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/tevent/tevent-0.9.19.ebuild')
-rw-r--r--sys-libs/tevent/tevent-0.9.19.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-libs/tevent/tevent-0.9.19.ebuild b/sys-libs/tevent/tevent-0.9.19.ebuild
new file mode 100644
index 000000000000..f91daca4209e
--- /dev/null
+++ b/sys-libs/tevent/tevent-0.9.19.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/tevent/tevent-0.9.19.ebuild,v 1.1 2013/08/06 11:55:07 polynomial-c Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_{6,7} )
+
+inherit waf-utils python-single-r1
+
+DESCRIPTION="Samba tevent library"
+HOMEPAGE="http://tevent.samba.org/"
+SRC_URI="http://samba.org/ftp/tevent/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=sys-libs/talloc-2.0.8[python]
+ ${PYTHON_DEPS}"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ waf-utils_src_install
+ insinto $(python_get_sitedir)
+ doins tevent.py
+}