summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/mozilla-launcher/mozilla-launcher-1.30.ebuild')
-rw-r--r--www-client/mozilla-launcher/mozilla-launcher-1.30.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/www-client/mozilla-launcher/mozilla-launcher-1.30.ebuild b/www-client/mozilla-launcher/mozilla-launcher-1.30.ebuild
new file mode 100644
index 000000000000..53b6780115da
--- /dev/null
+++ b/www-client/mozilla-launcher/mozilla-launcher-1.30.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-launcher/mozilla-launcher-1.30.ebuild,v 1.1 2005/03/24 21:07:01 agriffis Exp $
+
+DESCRIPTION="Script that launches mozilla or firefox"
+HOMEPAGE=""
+SRC_URI="mirror://gentoo/${P}.bz2 \
+ http://dev.gentoo.org/~agriffis/dist/${P}.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sparc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_install() {
+ exeinto /usr/libexec
+ newexe ${P} mozilla-launcher || die
+}
+
+pkg_postinst() {
+ local f
+
+ find ${ROOT}/usr/bin -maxdepth 1 -type l | \
+ while read f; do
+ [[ $(readlink ${f}) == mozilla-launcher ]] || continue
+ einfo "Updating ${f} symlink to /usr/libexec/mozilla-launcher"
+ ln -sfn /usr/libexec/mozilla-launcher ${f}
+ done
+}