summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/ratpoison/ratpoison-1.3.0_beta3-r2.ebuild')
-rw-r--r--x11-wm/ratpoison/ratpoison-1.3.0_beta3-r2.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/x11-wm/ratpoison/ratpoison-1.3.0_beta3-r2.ebuild b/x11-wm/ratpoison/ratpoison-1.3.0_beta3-r2.ebuild
new file mode 100644
index 000000000000..3331fa0c8a6b
--- /dev/null
+++ b/x11-wm/ratpoison/ratpoison-1.3.0_beta3-r2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ratpoison-1.3.0_beta3-r2.ebuild,v 1.1 2003/11/11 16:24:25 mkennedy Exp $
+
+inherit elisp-common
+
+DESCRIPTION="Ratpoison is an extremely light-weight and barebones wm modelled after screen"
+HOMEPAGE="http://ratpoison.sourceforge.net/"
+LICENSE="GPL-2"
+
+PV=`echo ${PV} | sed 's/_/-/'`
+P="${PN}-${PV}"
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~amd64"
+IUSE="emacs"
+S=${WORKDIR}/${P}
+
+DEPEND="x11-base/xfree
+ emacs? ( virtual/emacs )"
+
+SITEFILE=50ratpoison-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/contrib
+ epatch ${FILESDIR}/ratpoison.el-gentoo.patch
+}
+
+src_compile() {
+ if [ "${ARCH}" = "amd64" ]
+ then
+ libtoolize -c -f
+ fi
+ econf
+ emake CFLAGS="${CFLAGS} -I/usr/X11R6/include" || die
+ if use emacs; then
+ cd contrib && elisp-comp ratpoison.el
+ fi
+}
+
+src_install() {
+ einstall
+ cat >ratpoison <<EOF
+#!/bin/bash
+exec /usr/bin/ratpoison
+EOF
+ exeinto /etc/X11/Sessions
+ doexe ratpoison
+
+ dodoc INSTALL TODO README NEWS AUTHORS ChangeLog
+ docinto example
+ dodoc contrib/{genrpbindings,split.sh} doc/{ipaq.ratpoisonrc,sample.ratpoisonrc}
+
+ rm -rf $D/usr/share/{doc/ratpoison,ratpoison}
+
+ if use emacs; then
+ elisp-install ${PN} contrib/ratpoison.*
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}