aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tweepy/tweepy-2.1.ebuild')
-rw-r--r--dev-python/tweepy/tweepy-2.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/tweepy/tweepy-2.1.ebuild b/dev-python/tweepy/tweepy-2.1.ebuild
new file mode 100644
index 0000000..0866a0c
--- /dev/null
+++ b/dev-python/tweepy/tweepy-2.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tweepy/tweepy-2.0.ebuild,v 1.2 2013/09/05 18:46:58 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} pypy2_0 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="A Python library for accessing the Twitter API "
+HOMEPAGE="http://tweepy.github.com/"
+SRC_URI="https://github.com/tweepy/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+DOCS="README.md"
+RESTRICT="test" #fails all
+
+python_prepare_all() {
+ mv tests tweepy_tests || die "Failed to rename tests"
+}
+
+python_test() {
+ "${PYTHON}" -m tests || die "Tests failed"
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ dodoc ${DOCS}
+ use doc && dohtml -r docs/_build/html/
+
+ if use examples; then
+ docinto examples
+ dodoc examples/*
+ fi
+}