summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <g.dartiguelongue@lexfo.fr>2016-01-01 22:03:46 +0100
committerGilles Dartiguelongue <g.dartiguelongue@lexfo.fr>2016-01-01 22:03:46 +0100
commitf9b48d487586da76212c88e23506bc0a2d66f760 (patch)
treeaf7f4ead3040caf334b7d4d842df4f2a4e428792
parentdev-db/glom: version bump to 1.30 (diff)
downloadeva-f9b48d487586da76212c88e23506bc0a2d66f760.tar.gz
eva-f9b48d487586da76212c88e23506bc0a2d66f760.tar.bz2
eva-f9b48d487586da76212c88e23506bc0a2d66f760.zip
dev-php/PEAR-HTTP_WebDAV_Client: initial ebuild
-rw-r--r--dev-php/PEAR-HTTP_WebDAV_Client/Manifest1
-rw-r--r--dev-php/PEAR-HTTP_WebDAV_Client/PEAR-HTTP_WebDAV_Client-1.0.2.ebuild24
-rw-r--r--dev-php/PEAR-HTTP_WebDAV_Client/files/fix-propfind-response-parser.patch13
-rw-r--r--dev-php/PEAR-HTTP_WebDAV_Client/metadata.xml11
4 files changed, 49 insertions, 0 deletions
diff --git a/dev-php/PEAR-HTTP_WebDAV_Client/Manifest b/dev-php/PEAR-HTTP_WebDAV_Client/Manifest
new file mode 100644
index 0000000..e59d74b
--- /dev/null
+++ b/dev-php/PEAR-HTTP_WebDAV_Client/Manifest
@@ -0,0 +1 @@
+DIST HTTP_WebDAV_Client-1.0.2.tgz 9000 SHA256 4c2058ab69589bbe20fa97004ac84259e0392975ce31dcdd0cb95ed24d33fde5 SHA512 b124d417cc93a01f1571044aceb1aaa6962f777411cbf9fa0c9c8d303980ff5b6272499c4be6a501f878cf2d7a5ff521f6a83f0a2a9491095971156264abdb53 WHIRLPOOL aabf80b47f6f3cd857303ea1f4ba08ddd0975de6ae941346b1a4acdbd87a382283946520fc00510c1b7ac33ceb629ce9bfc92512a741dca5754036804cc2d868
diff --git a/dev-php/PEAR-HTTP_WebDAV_Client/PEAR-HTTP_WebDAV_Client-1.0.2.ebuild b/dev-php/PEAR-HTTP_WebDAV_Client/PEAR-HTTP_WebDAV_Client-1.0.2.ebuild
new file mode 100644
index 0000000..e86f669
--- /dev/null
+++ b/dev-php/PEAR-HTTP_WebDAV_Client/PEAR-HTTP_WebDAV_Client-1.0.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit php-pear-r1 eutils
+
+DESCRIPTION="WebDAV stream wrapper class"
+
+LICENSE="PHP"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/PEAR-HTTP_Request
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/fix-propfind-response-parser.patch
+}
diff --git a/dev-php/PEAR-HTTP_WebDAV_Client/files/fix-propfind-response-parser.patch b/dev-php/PEAR-HTTP_WebDAV_Client/files/fix-propfind-response-parser.patch
new file mode 100644
index 0000000..c83ee91
--- /dev/null
+++ b/dev-php/PEAR-HTTP_WebDAV_Client/files/fix-propfind-response-parser.patch
@@ -0,0 +1,13 @@
+--- HTTP/WebDAV/Tools/_parse_propfind_response.php.orig 2015-06-15 22:46:16.736000000 +0200
++++ HTTP/WebDAV/Tools/_parse_propfind_response.php 2015-06-15 22:46:23.841000000 +0200
+@@ -98,9 +98,7 @@
+ $this->_tmpprop['mtime'] = strtotime($this->_tmpdata);
+ break;
+ case 'creationdate':
+- $t = preg_split("/[^[:digit:]]/", $this->_tmpdata);
+- $this->_tmpprop['ctime'] = mktime($t[3], $t[4], $t[5], $t[1], $t[2], $t[0]);
+- unset($t);
++ $this->_tmpprop['ctime'] = strtotime($this->_tmpdata);
+ break;
+ case 'getcontentlength':
+ $this->_tmpprop['size'] = $this->_tmpdata;
diff --git a/dev-php/PEAR-HTTP_WebDAV_Client/metadata.xml b/dev-php/PEAR-HTTP_WebDAV_Client/metadata.xml
new file mode 100644
index 0000000..6b61b72
--- /dev/null
+++ b/dev-php/PEAR-HTTP_WebDAV_Client/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>eva@gentoo.org</email>
+ <name>Gilles Dartiguelongue</name>
+</maintainer>
+<upstream>
+ <remote-id type="github">pear/HTTP_WebDAV_Client</remote-id>
+</upstream>
+</pkgmetadata>