summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-11-27 19:23:35 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2011-11-27 19:23:35 +0100
commitb79727b9e22d728c4a9a7fad81318aee9e060010 (patch)
tree1151683c08d60d47011e89e899f7ad9b141ee656 /media-gfx
parentgames-puzzle/gbrainy: version bump (diff)
downloadeva-b79727b9e22d728c4a9a7fad81318aee9e060010.tar.gz
eva-b79727b9e22d728c4a9a7fad81318aee9e060010.tar.bz2
eva-b79727b9e22d728c4a9a7fad81318aee9e060010.zip
media-gfx/eog-plugins: initial commit
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/eog-plugins/Manifest11
-rw-r--r--media-gfx/eog-plugins/eog-plugins-3.2.2.ebuild53
-rw-r--r--media-gfx/eog-plugins/metadata.xml13
3 files changed, 77 insertions, 0 deletions
diff --git a/media-gfx/eog-plugins/Manifest b/media-gfx/eog-plugins/Manifest
new file mode 100644
index 0000000..b9558e3
--- /dev/null
+++ b/media-gfx/eog-plugins/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST eog-plugins-3.2.2.tar.xz 308244 RMD160 96edc5ec74f054a68bf605ab071580fdd87364e6 SHA1 61881eeac777958bf878415b9aaeb0ccd9bd303c SHA256 123e50be69c33bddc5d6def0a1f618970e01207c2e959edbaf0afc56717d8975
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.18 (GNU/Linux)
+
+iEYEARECAAYFAk7SgCcACgkQ1fmVwcYIWAYSaACaA5jWeTA9vw90z9ZjQE4jFaxH
+9n0An3vfpluP4j1VXjoL/5pkp5I9LZ8x
+=5cq2
+-----END PGP SIGNATURE-----
diff --git a/media-gfx/eog-plugins/eog-plugins-3.2.2.ebuild b/media-gfx/eog-plugins/eog-plugins-3.2.2.ebuild
new file mode 100644
index 0000000..94eaa64
--- /dev/null
+++ b/media-gfx/eog-plugins/eog-plugins-3.2.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+GCONF_DEBUG="no"
+PYTHON_DEPEND="python? 2:2.5"
+
+inherit gnome2 python
+
+DESCRIPTION="This package contains some useful plugins for the Eye of GNOME image viewer."
+HOMEPAGE="http://live.gnome.org/Eog"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="exif map picasa python"
+
+RDEPEND="
+ >=dev-libs/glib-2.26:2
+ >=dev-libs/libpeas-0.7.4
+ >=media-gfx/eog-2.91.92
+ >=x11-libs/gtk+-2.99.3:3
+ exif? ( >=media-libs/libexif-0.6.16 )
+ map? (
+ >=media-libs/libchamplain-0.9:0.12
+ >=media-libs/clutter-gtk-0.90:1.0
+ >=media-libs/libexif-0.6.16 )
+ picasa? ( >=dev-libs/libgdata-0.9 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ dev-util/pkgconfig
+"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS"
+
+ # postr map fit-to-width exif-display send-by-mail postasa
+ # XXX: postr is not available in gentoo
+ local plugins="fit-to-width,send-by-mail"
+ use exif && plugins="$plugins,exif-display"
+ use map && plugins="$plugins,map"
+ use picasa && plugins="$plugins,postasa"
+ use python && plugins="$plugins,slideshowshuffle pythonconsole"
+
+ G2CONF="${G2CONF}
+ --disable-schemas-compile
+ $(use_enable python)
+ --with-plugins=$plugins"
+
+ python_pkg_setup
+}
diff --git a/media-gfx/eog-plugins/metadata.xml b/media-gfx/eog-plugins/metadata.xml
new file mode 100644
index 0000000..4e00f46
--- /dev/null
+++ b/media-gfx/eog-plugins/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>eva@gentoo.org</email>
+ <name>Gilles Dartiguelongue</name>
+</maintainer>
+<use>
+ <flag name="map">Show geographic information on a map.</flag>
+ <flag name="picasa">Enable integration with Picasa web service.</flag>
+</use>
+</pkgmetadata>