summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-12-24 18:45:11 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-12-24 18:45:11 +0000
commita8badc8f7e0ef8a2550de0f494b2bb6eb2a83236 (patch)
treeecadd73c112f17204d3343f3b8f52d94c2abe853
parentwargus fitting for new stratagus, not working error: Can't open file 'prefere... (diff)
downloadgenstef-a8badc8f7e0ef8a2550de0f494b2bb6eb2a83236.tar.gz
genstef-a8badc8f7e0ef8a2550de0f494b2bb6eb2a83236.tar.bz2
genstef-a8badc8f7e0ef8a2550de0f494b2bb6eb2a83236.zip
bos fitting for new stratagus, not working, error in error handling
svn path=/; revision=94
-rw-r--r--games-strategy/bos/bos-2.0.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/games-strategy/bos/bos-2.0.1.ebuild b/games-strategy/bos/bos-2.0.1.ebuild
new file mode 100644
index 0000000..219758f
--- /dev/null
+++ b/games-strategy/bos/bos-2.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/bos/bos-1.1.ebuild,v 1.4 2006/09/28 21:34:13 nyhm Exp $
+
+inherit eutils games
+
+MY_P=${PN}_${PV//./_}
+DESCRIPTION="Invasion - Battle of Survival is a real-time strategy game using the Stratagus game engine"
+HOMEPAGE="http://bos.seul.org/"
+SRC_URI="http://bos.seul.org/files/${MY_P}.tar.gz
+ http://dev.gentoo.org/~genstef/files/bos.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="=games-engines/stratagus-2.2*"
+
+S=${WORKDIR}/data.bos
+
+src_install() {
+ dodir "${GAMES_BINDIR}"
+ echo "${GAMES_BINDIR}/stratagus -d \"${GAMES_DATADIR}\"/${PN} \$*" >> "${D}${GAMES_BINDIR}/${PN}"
+ insinto "${GAMES_DATADIR}/${PN}"
+
+ dodoc CHANGELOG README.txt
+ rm CHANGELOG README.txt COPYRIGHT.txt LICENSE.txt
+
+ doins -r * || die "doins failed"
+
+ doicon "${DISTDIR}"/bos.png
+ make_desktop_entry ${PN} "Invasion - Battle of Survival"
+ prepgamesdirs
+}