summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin F. Quinn <kevquinn@gentoo.org>2006-12-17 20:14:11 +0000
committerKevin F. Quinn <kevquinn@gentoo.org>2006-12-17 20:14:11 +0000
commit1de9d1d1065c3ff5dd9242156bc2512cb96abb81 (patch)
tree7950d14b9d26d9d4b5fc309d7e353e93b8889099
parentAnother sed error on Makefile.in crtstuff (diff)
downloadkevquinn-1de9d1d1065c3ff5dd9242156bc2512cb96abb81.tar.gz
kevquinn-1de9d1d1065c3ff5dd9242156bc2512cb96abb81.tar.bz2
kevquinn-1de9d1d1065c3ff5dd9242156bc2512cb96abb81.zip
last sed fix - honest!
svn path=/; revision=121
-rw-r--r--hardened/toolchain/eclass/toolchain.eclass2
1 files changed, 1 insertions, 1 deletions
diff --git a/hardened/toolchain/eclass/toolchain.eclass b/hardened/toolchain/eclass/toolchain.eclass
index 041bb84..a01317f 100644
--- a/hardened/toolchain/eclass/toolchain.eclass
+++ b/hardened/toolchain/eclass/toolchain.eclass
@@ -2162,7 +2162,7 @@ do_gcc_PIE_patches() {
sed -e '/^CRTSTUFF_T_CFLAGS_S =/iCRTSTUFF_T_CFLAGS = -fno-PIE' \
-i "${S}"/gcc/config/t-linux ||
die "Failed to fixup gcc/config/t-linux for no-PIE crtstuff"
- sed -e 's/^CRTSTUFF_T_CFLAGS =/CRTSTUFF_T_CFLAGS = -fno-PIE' \
+ sed -e 's/^CRTSTUFF_T_CFLAGS =/CRTSTUFF_T_CFLAGS = -fno-PIE /' \
-i "${S}"/gcc/Makefile.in ||
die "Failed to fixup gcc/Makefile.in for no-PIE crtstuff"
# adds default pie support (rs6000 too) if DEFAULT_PIE[_SSP] is defined