summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'hardened/toolchain/branches/pieworld/sys-libs/glibc/glibc-2.5-r1.ebuild')
-rw-r--r--hardened/toolchain/branches/pieworld/sys-libs/glibc/glibc-2.5-r1.ebuild20
1 files changed, 0 insertions, 20 deletions
diff --git a/hardened/toolchain/branches/pieworld/sys-libs/glibc/glibc-2.5-r1.ebuild b/hardened/toolchain/branches/pieworld/sys-libs/glibc/glibc-2.5-r1.ebuild
index 6f8463b..6feb1dc 100644
--- a/hardened/toolchain/branches/pieworld/sys-libs/glibc/glibc-2.5-r1.ebuild
+++ b/hardened/toolchain/branches/pieworld/sys-libs/glibc/glibc-2.5-r1.ebuild
@@ -739,23 +739,6 @@ setup_flags() {
# Don't let the compiler automatically build PIEs unless USE=hardened.
use hardened || filter-flags -fPIE
-
- # When building hardened, define PIC always as many files use libtool-style
- # macro PIC rather than the builtin macro __PIC__ to differentiate.
-#1 if use hardened; then
-#1 mkdir -p ${T}/include
-#1 [[ -f ${T}/include/define-pic.h ]] ||
-#1 cat > ${T}/include/define-pic.h <<-EOF
-#1 #if defined __PIC__ && !defined PIC
-#1 # define PIC
-#1 #endif
-#1 EOF
-#1 append-flags "-I${T}/include -imacrosdefine-pic.h"
-#1 # Note; the glibc build process filters out -I* from CFLAGS -
-#1 # define-pic.h will be moved to the build directory in
-#1 # the configure phase.
-#1 fi
-#2 #use hardened && append-flags -DPIC
}
check_kheader_version() {
@@ -954,9 +937,6 @@ glibc_do_configure() {
local GBUILDDIR=${WORKDIR}/build-${ABI}-${CTARGET}-$1
mkdir -p "${GBUILDDIR}"
cd "${GBUILDDIR}"
-#1 # Copy define-pic.h into the build directory, where glibc's build process
-#1 # will find it.
-#1 use hardened && cp ${T}/include/define-pic.h .
einfo "Configuring GLIBC for $1 with: ${myconf// /\n\t\t}"
"${S}"/configure ${myconf} || die "failed to configure glibc"
}