summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/xmlrpc-c/files/xmlrpc-c-1.16.08-build-tools.patch')
-rw-r--r--dev-libs/xmlrpc-c/files/xmlrpc-c-1.16.08-build-tools.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/xmlrpc-c/files/xmlrpc-c-1.16.08-build-tools.patch b/dev-libs/xmlrpc-c/files/xmlrpc-c-1.16.08-build-tools.patch
new file mode 100644
index 0000000..0c070d5
--- /dev/null
+++ b/dev-libs/xmlrpc-c/files/xmlrpc-c-1.16.08-build-tools.patch
@@ -0,0 +1,47 @@
+diff -NrU5 xmlrpc-c-1.16.08.orig/GNUmakefile xmlrpc-c-1.16.08/GNUmakefile
+--- xmlrpc-c-1.16.08.orig/GNUmakefile 2008-12-29 05:12:25.000000000 +0100
++++ xmlrpc-c-1.16.08/GNUmakefile 2009-01-21 09:45:03.000000000 +0100
+@@ -23,11 +23,11 @@
+
+ DEFAULT_SUBDIRS = include lib src
+
+ PROGRAMS_TO_INSTALL = xmlrpc-c-config
+
+-default: xmlrpc-c-config xmlrpc-c-config.test $(DEFAULT_SUBDIRS:%=%/all)
++default: xmlrpc-c-config xmlrpc-c-config.test $(DEFAULT_SUBDIRS:%=%/all) tools/all
+
+ # We don't want common.mk's rule for version.h
+ OMIT_VERSION_H = Y
+
+ # We don't want common.mk's rule for transport_config.h
+@@ -153,11 +153,11 @@
+
+ .PHONY: distdir
+ distdir: distdir-common
+
+ .PHONY: install
+-install: $(DEFAULT_SUBDIRS:%=%/install) install-common
++install: $(DEFAULT_SUBDIRS:%=%/install) tools/install install-common
+
+ .PHONY: dep
+ dep: version.h $(BLDDIR)/include/xmlrpc-c/config.h $(SUBDIRS:%=%/dep)
+
+ xmlrpc_config.h xmlrpc_amconfig.h \
+diff -NrU5 xmlrpc-c-1.16.08.orig/tools/Makefile xmlrpc-c-1.16.08/tools/Makefile
+--- xmlrpc-c-1.16.08.orig/tools/Makefile 2008-12-29 05:12:25.000000000 +0100
++++ xmlrpc-c-1.16.08/tools/Makefile 2009-01-21 09:15:19.000000000 +0100
+@@ -11,13 +11,11 @@
+
+ ifeq ($(MUST_BUILD_CLIENT),yes)
+ SUBDIRS += xmlrpc xmlrpc_transport
+
+ ifeq ($(ENABLE_CPLUSPLUS),yes)
+- SUBDIRS += xml-rpc-api2cpp xmlrpc_cpp_proxy
+- # We could add 'xmlrpc_pstream' here, but we don't because we don't
+- # want to deal with finding the Readline/Ncurses libraries.
++ SUBDIRS += xml-rpc-api2cpp xmlrpc_cpp_proxy xmlrpc_pstream
+ endif
+ endif
+
+ .PHONY: all clean distclean install check dep
+