summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/sup/sup-0.9.1.ebuild')
-rw-r--r--mail-client/sup/sup-0.9.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/mail-client/sup/sup-0.9.1.ebuild b/mail-client/sup/sup-0.9.1.ebuild
new file mode 100644
index 0000000..43e3048
--- /dev/null
+++ b/mail-client/sup/sup-0.9.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+inherit gems
+
+DESCRIPTION="a console-based email client for people with a lot of email"
+HOMEPAGE="http://sup.rubyforge.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-ruby/ferret-0.11.6
+ dev-ruby/highline
+ dev-ruby/lockfile
+ >=dev-ruby/mime-types-1
+ >=dev-ruby/ncurses-ruby-0.9.1
+ dev-ruby/net-ssh
+ dev-ruby/ruby-gettext
+ >=dev-ruby/ruby-rmail-0.17
+ >=dev-ruby/trollop-1.12
+ dev-ruby/fastthread"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ gems_src_install
+ rm "${D}${GEMSDIR}/gems/${P}/lib/ncurses.rb" || die
+}
+