summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2023-12-05 10:04:27 +0100
committerMarc Schiffbauer <mschiff@gentoo.org>2023-12-05 10:04:27 +0100
commit2b688e4d526f365d0bfd99d2c403bb76f34ae156 (patch)
treea7c6ee01e408da6e8160da5aceca512c9f225630
parentapp-editors/logseq-desktop-bin: add 0.10.0, drop 0.9.19 (diff)
downloadmschiff-2b688e4d526f365d0bfd99d2c403bb76f34ae156.tar.gz
mschiff-2b688e4d526f365d0bfd99d2c403bb76f34ae156.tar.bz2
mschiff-2b688e4d526f365d0bfd99d2c403bb76f34ae156.zip
add www-apps/bareos-webui
Signed-off-by: Marc Schiffbauer <mschiff@gentoo.org>
-rw-r--r--www-apps/bareos-webui/Manifest1
-rw-r--r--www-apps/bareos-webui/bareos-webui-22.1.0.ebuild121
-rw-r--r--www-apps/bareos-webui/bareos-webui-9999.ebuild121
-rw-r--r--www-apps/bareos-webui/files/bareos-webui-20.0.2.ebuild75
-rw-r--r--www-apps/bareos-webui/files/bareos-webui-inode64-22.1.1.ebuild68
-rw-r--r--www-apps/bareos-webui/files/bareos-webui-my-20.0.2.ebuild85
-rw-r--r--www-apps/bareos-webui/files/postinstall-en.txt20
-rw-r--r--www-apps/bareos-webui/metadata.xml11
8 files changed, 502 insertions, 0 deletions
diff --git a/www-apps/bareos-webui/Manifest b/www-apps/bareos-webui/Manifest
new file mode 100644
index 0000000..ede21f5
--- /dev/null
+++ b/www-apps/bareos-webui/Manifest
@@ -0,0 +1 @@
+DIST bareos-22.1.0.tar.gz 14719993 BLAKE2B 38e354d3227d401c69ffb003c83ae90c2067720490af089d529da636bc300e2fb5042451ab439b8b102f6850aeadbe8dedc4311dba13f800eab0bc77d89f809d SHA512 dea64c6eb34a93f1a93eb6b0ac628a75101ac8873e06800a256f226e8f3a556fe39ce4e500246f9c51de30a2b0907732f789c6394f29b7bb9d983a64c709ad2c
diff --git a/www-apps/bareos-webui/bareos-webui-22.1.0.ebuild b/www-apps/bareos-webui/bareos-webui-22.1.0.ebuild
new file mode 100644
index 0000000..24c1327
--- /dev/null
+++ b/www-apps/bareos-webui/bareos-webui-22.1.0.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_WARN_UNUSED_CLI=no
+CMAKE_MAKEFILE_GENERATOR="emake"
+
+MY_PV=${PV/_/-}
+MY_PN="bareos"
+MY_P="${MY_PN}-${MY_PV}"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit cmake webapp git-r3
+ S=${WORKDIR}/${PF}/webui
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/${MY_PN}/${MY_PN}.git"
+ KEYWORDS=""
+else
+ inherit cmake webapp
+ S=${WORKDIR}/${MY_PN}-Release-${PV}/webui
+ SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/Release/${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Featureful client/server network backup suite"
+HOMEPAGE="https://www.bareos.org/"
+RESTRICT="mirror"
+
+LICENSE="AGPL-3"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-lang/php[bzip2,ctype,curl,fileinfo,filter,fpm,gd,iconv,intl,mhash,nls,pdo,postgres,session,simplexml,ssl,xml,xmlreader,xmlwriter,zip]
+ virtual/httpd-php
+"
+
+need_httpd_fastcgi
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_prepare() {
+ # fix missing VERSION
+ sed -i "s/@BAREOS_FULL_VERSION@/${PV}/g" version.php.in || die
+
+ cmake_src_prepare
+ default
+}
+
+src_configure() {
+ if [[ ${PV} == 9999 ]]; then
+ pushd "${WORKDIR}/${PF}"
+ else
+ pushd "${S}"/..
+ fi
+ CURRENT_VERSION=$(echo $(cmake -P get_version.cmake) | sed 's/[- ]//g')
+ popd
+ local mycmakeargs=(
+ -DVERSION_STRING=${CURRENT_VERSION}
+ -Wno-dev
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc README.md doc/README-TRANSLATION.md
+
+ dodir "/etc/bareos/bareos-dir.d"
+ cp -r install/bareos/bareos-dir.d/* "${D}/etc/bareos/bareos-dir.d"
+
+ sed -i -e "s,/var/www/bareos-webui/,${MY_HTDOCSDIR}," "install/nginx/bareos-webui.conf"
+ sed -i -e "s,/usr/share/bareos-webui/,${MY_HTDOCSDIR}," "install/apache/bareos-webui.conf"
+
+ webapp_server_configfile nginx "install/nginx/bareos-webui.conf" bareos-webui.include
+ webapp_server_configfile apache "install/apache/bareos-webui.conf" bareos-webui.conf
+
+ insinto /etc/${PN}
+ doins install/{configuration,directors}.ini
+
+ insinto "${MY_HTDOCSDIR#${EPREFIX}}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR#${EPREFIX}}"/config/application.config.php
+ webapp_configfile "${MY_HTDOCSDIR#${EPREFIX}}"/config/autoload/global.php
+
+ keepdir "${MY_HTDOCSDIR#${EPREFIX}}"/data
+ webapp_serverowned "${MY_HTDOCSDIR#${EPREFIX}}"/data
+
+ # cleanup
+ find "${D}/${MY_HTDOCSDIR#${EPREFIX}}" -name "*.in" -delete
+ rm -rf "${D}/${MY_HTDOCSDIR#${EPREFIX}}"/{CMakeLists.txt,install,cmake,phpunit.xml,scripts,doc,tests}
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "The webui uses 'webapp-config' to be configured. To install it may be called like so:"
+ einfo ""
+ einfo " webapp-config -h localhost -d bareos-webui -I bareos-webui ${PV}"
+ einfo ""
+ einfo "See 'man webapp-config' for more details."
+ einfo ""
+ einfo "For more details about how to configure the bareos webui, see:"
+ einfo " https://docs.bareos.org/IntroductionAndTutorial/InstallingBareosWebui.html"
+ einfo ""
+ ewarn ""
+ ewarn "You need to configure your webserver!"
+ ewarn "vhost configuration templates can be found under /usr/share/webapps/bareos-webui/${PV}/conf"
+ ewarn ""
+ ewarn "IMPORTANT: make sure the docroot of your webserver points to the public/ folder within webapp htdocs directory"
+ ewarn ""
+}
diff --git a/www-apps/bareos-webui/bareos-webui-9999.ebuild b/www-apps/bareos-webui/bareos-webui-9999.ebuild
new file mode 100644
index 0000000..24c1327
--- /dev/null
+++ b/www-apps/bareos-webui/bareos-webui-9999.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_WARN_UNUSED_CLI=no
+CMAKE_MAKEFILE_GENERATOR="emake"
+
+MY_PV=${PV/_/-}
+MY_PN="bareos"
+MY_P="${MY_PN}-${MY_PV}"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit cmake webapp git-r3
+ S=${WORKDIR}/${PF}/webui
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/${MY_PN}/${MY_PN}.git"
+ KEYWORDS=""
+else
+ inherit cmake webapp
+ S=${WORKDIR}/${MY_PN}-Release-${PV}/webui
+ SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/Release/${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Featureful client/server network backup suite"
+HOMEPAGE="https://www.bareos.org/"
+RESTRICT="mirror"
+
+LICENSE="AGPL-3"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-lang/php[bzip2,ctype,curl,fileinfo,filter,fpm,gd,iconv,intl,mhash,nls,pdo,postgres,session,simplexml,ssl,xml,xmlreader,xmlwriter,zip]
+ virtual/httpd-php
+"
+
+need_httpd_fastcgi
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_prepare() {
+ # fix missing VERSION
+ sed -i "s/@BAREOS_FULL_VERSION@/${PV}/g" version.php.in || die
+
+ cmake_src_prepare
+ default
+}
+
+src_configure() {
+ if [[ ${PV} == 9999 ]]; then
+ pushd "${WORKDIR}/${PF}"
+ else
+ pushd "${S}"/..
+ fi
+ CURRENT_VERSION=$(echo $(cmake -P get_version.cmake) | sed 's/[- ]//g')
+ popd
+ local mycmakeargs=(
+ -DVERSION_STRING=${CURRENT_VERSION}
+ -Wno-dev
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc README.md doc/README-TRANSLATION.md
+
+ dodir "/etc/bareos/bareos-dir.d"
+ cp -r install/bareos/bareos-dir.d/* "${D}/etc/bareos/bareos-dir.d"
+
+ sed -i -e "s,/var/www/bareos-webui/,${MY_HTDOCSDIR}," "install/nginx/bareos-webui.conf"
+ sed -i -e "s,/usr/share/bareos-webui/,${MY_HTDOCSDIR}," "install/apache/bareos-webui.conf"
+
+ webapp_server_configfile nginx "install/nginx/bareos-webui.conf" bareos-webui.include
+ webapp_server_configfile apache "install/apache/bareos-webui.conf" bareos-webui.conf
+
+ insinto /etc/${PN}
+ doins install/{configuration,directors}.ini
+
+ insinto "${MY_HTDOCSDIR#${EPREFIX}}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR#${EPREFIX}}"/config/application.config.php
+ webapp_configfile "${MY_HTDOCSDIR#${EPREFIX}}"/config/autoload/global.php
+
+ keepdir "${MY_HTDOCSDIR#${EPREFIX}}"/data
+ webapp_serverowned "${MY_HTDOCSDIR#${EPREFIX}}"/data
+
+ # cleanup
+ find "${D}/${MY_HTDOCSDIR#${EPREFIX}}" -name "*.in" -delete
+ rm -rf "${D}/${MY_HTDOCSDIR#${EPREFIX}}"/{CMakeLists.txt,install,cmake,phpunit.xml,scripts,doc,tests}
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "The webui uses 'webapp-config' to be configured. To install it may be called like so:"
+ einfo ""
+ einfo " webapp-config -h localhost -d bareos-webui -I bareos-webui ${PV}"
+ einfo ""
+ einfo "See 'man webapp-config' for more details."
+ einfo ""
+ einfo "For more details about how to configure the bareos webui, see:"
+ einfo " https://docs.bareos.org/IntroductionAndTutorial/InstallingBareosWebui.html"
+ einfo ""
+ ewarn ""
+ ewarn "You need to configure your webserver!"
+ ewarn "vhost configuration templates can be found under /usr/share/webapps/bareos-webui/${PV}/conf"
+ ewarn ""
+ ewarn "IMPORTANT: make sure the docroot of your webserver points to the public/ folder within webapp htdocs directory"
+ ewarn ""
+}
diff --git a/www-apps/bareos-webui/files/bareos-webui-20.0.2.ebuild b/www-apps/bareos-webui/files/bareos-webui-20.0.2.ebuild
new file mode 100644
index 0000000..ecff243
--- /dev/null
+++ b/www-apps/bareos-webui/files/bareos-webui-20.0.2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_WARN_UNUSED_CLI=no
+CMAKE_REMOVE_MODULES=yes
+
+inherit cmake-utils eutils webapp git-r3
+
+MY_PV=${PV/_/-}
+MY_PN="bareos"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Featureful client/server network backup suite"
+HOMEPAGE="https://www.bareos.org/"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/${MY_PN}/${MY_PN}.git"
+RESTRICT="mirror"
+
+LICENSE="AGPL-3"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="mysql +postgres"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-lang/php[mysql?,pdo,postgres?]
+ virtual/httpd-php
+"
+
+need_httpd_cgi
+
+S=${WORKDIR}/${PF}/webui
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_configure() {
+ pushd ${WORKDIR}/${PF}
+ CURRENT_VERSION=$(echo $(cmake -P get_version.cmake) | sed 's/[- ]//g')
+ popd
+ local mycmakeargs=(
+ -DVERSION_STRING=${CURRENT_VERSION}
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc LICENSE README.md
+ webapp_server_configfile nginx ${S}/install/nginx/bareos-webui.conf bareos-webui.include
+ webapp_server_configfile apache ${S}/install/apache/bareos-webui.conf bareos-webui.conf
+# webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ insinto "${MY_HTDOCSDIR#${EPREFIX}}"
+ pushd "${BUILD_DIR}" > /dev/null || die
+ DESTDIR="${D}/${MY_HTDOCSDIR#${EPREFIX}}" ${CMAKE_MAKEFILE_GENERATOR} install "$@" || die "died running ${CMAKE_MAKEFILE_GENERATOR} install"
+ popd > /dev/null || die
+
+ webapp_configfile "${MY_HTDOCSDIR#${EPREFIX}}"/bareos-webui/config/application.config.php
+ webapp_configfile "${MY_HTDOCSDIR#${EPREFIX}}"/bareos-webui/config/autoload/global.php
+
+ mv "${D}/${MY_HTDOCSDIR#${EPREFIX}}"/bareos-webui/* "${D}/${MY_HTDOCSDIR#${EPREFIX}}"/
+ rmdir "${D}/${MY_HTDOCSDIR#${EPREFIX}}"/bareos-webui
+ find "${D}/${MY_HTDOCSDIR#${EPREFIX}}" -type f -name '*.in' -delete
+
+ mv "${D}/${MY_HTDOCSDIR#${EPREFIX}}/etc" "${D}/etc"
+ rm -rf "${D}/etc/httpd"
+
+ webapp_src_install
+}
diff --git a/www-apps/bareos-webui/files/bareos-webui-inode64-22.1.1.ebuild b/www-apps/bareos-webui/files/bareos-webui-inode64-22.1.1.ebuild
new file mode 100644
index 0000000..810e63c
--- /dev/null
+++ b/www-apps/bareos-webui/files/bareos-webui-inode64-22.1.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_WARN_UNUSED_CLI=no
+
+inherit cmake webapp
+
+MY_PV=${PV/_/-}
+MY_PN="bareos"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Featureful client/server network backup suite"
+HOMEPAGE="https://www.bareos.com/"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/Release/${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+RESTRICT="mirror"
+
+LICENSE="AGPL-3"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-lang/php[bzip2,ctype,curl,fileinfo,filter,gd,iconv,intl,mhash,nls,pdo,postgres,session,simplexml,ssl,xml,xmlreader,xmlwriter,zip]
+ virtual/httpd-php
+"
+need_httpd_cgi
+
+S=${WORKDIR}/${MY_PN}-Release-${PV}/webui
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_prepare() {
+ # fix missing VERSION
+ sed -i "s/@BAREOS_FULL_VERSION@/${PV}/g" version.php.in || die
+
+ cmake_src_prepare
+}
+
+src_install() {
+ webapp_src_preinst
+
+ # remove tests
+ rm -rf "${D}/tests" 2>/dev/null || die
+
+ dodoc README.md
+ webapp_server_configfile nginx "${S}/install/nginx/bareos-webui.conf" bareos-webui.include
+ webapp_server_configfile apache "${S}/install/apache/bareos-webui.conf" bareos-webui.conf
+
+ insinto "${MY_HTDOCSDIR}"
+ pushd "${BUILD_DIR}" >/dev/null || die
+ DESTDIR="${D}/${MY_HTDOCSDIR}" ${CMAKE_MAKEFILE_GENERATOR} install "$@" || die "died running ${CMAKE_MAKEFILE_GENERATOR} install"
+ popd >/dev/null || die
+
+ mv "${D}/${MY_HTDOCSDIR}"/usr/share/bareos-webui/* "${D}/${MY_HTDOCSDIR}"/
+ rmdir "${D}/${MY_HTDOCSDIR}"/usr/share/bareos-webui
+
+ find "${D}/${MY_HTDOCSDIR}" -type f -name '*.in' -delete
+ find "${D}/${MY_HTDOCSDIR}" -type f -name '*.map' -delete
+
+ mv "${D}/${MY_HTDOCSDIR}/etc" "${D}/etc"
+ rm -rf "${D}/etc/httpd"
+
+ webapp_src_install
+}
diff --git a/www-apps/bareos-webui/files/bareos-webui-my-20.0.2.ebuild b/www-apps/bareos-webui/files/bareos-webui-my-20.0.2.ebuild
new file mode 100644
index 0000000..59e682d
--- /dev/null
+++ b/www-apps/bareos-webui/files/bareos-webui-my-20.0.2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_WARN_UNUSED_CLI=no
+CMAKE_REMOVE_MODULES_LIST=()
+
+MY_PV=${PV/_/-}
+MY_PN="bareos"
+MY_P="${MY_PN}-${MY_PV}"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit cmake webapp git-r3
+ S=${WORKDIR}/${PF}/webui
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/${MY_PN}/${MY_PN}.git"
+ KEYWORDS=""
+else
+ inherit webapp
+ S=${WORKDIR}/${MY_PN}-Release-${PV}/webui
+ SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/Release/${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Featureful client/server network backup suite"
+HOMEPAGE="https://www.bareos.org/"
+RESTRICT="mirror"
+
+LICENSE="AGPL-3"
+
+IUSE="mysql +postgres"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-lang/php[mysql?,pdo,postgres?]
+ virtual/httpd-php
+"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_configure() {
+ if [[ ${PV} == 9999 ]]; then
+ pushd "${WORKDIR}/${PF}"
+ CURRENT_VERSION=$(echo $(cmake -P get_version.cmake) | sed 's/[- ]//g')
+ popd
+ local mycmakeargs=(
+ -DVERSION_STRING=${CURRENT_VERSION}
+ )
+
+ cmake_src_configure
+ else
+ default
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc README.md
+ webapp_server_configfile nginx "${S}/install/nginx/bareos-webui.conf" bareos-webui.include
+ webapp_server_configfile apache "${S}/install/apache/bareos-webui.conf" bareos-webui.conf
+# webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ insinto "${MY_HTDOCSDIR#${EPREFIX}}"
+ pushd "${BUILD_DIR}" > /dev/null || die
+ DESTDIR="${D}/${MY_HTDOCSDIR#${EPREFIX}}" ${CMAKE_MAKEFILE_GENERATOR} install "$@" || die "died running ${CMAKE_MAKEFILE_GENERATOR} install"
+ popd > /dev/null || die
+
+ webapp_configfile "${MY_HTDOCSDIR#${EPREFIX}}"/bareos-webui/config/application.config.php
+ webapp_configfile "${MY_HTDOCSDIR#${EPREFIX}}"/bareos-webui/config/autoload/global.php
+
+ mv "${D}/${MY_HTDOCSDIR#${EPREFIX}}"/bareos-webui/* "${D}/${MY_HTDOCSDIR#${EPREFIX}}"/
+ rmdir "${D}/${MY_HTDOCSDIR#${EPREFIX}}"/bareos-webui
+ find "${D}/${MY_HTDOCSDIR#${EPREFIX}}" -type f -name '*.in' -delete
+
+ mv "${D}/${MY_HTDOCSDIR#${EPREFIX}}/etc" "${D}/etc"
+ rm -rf "${D}/etc/httpd"
+
+ webapp_src_install
+}
diff --git a/www-apps/bareos-webui/files/postinstall-en.txt b/www-apps/bareos-webui/files/postinstall-en.txt
new file mode 100644
index 0000000..1b9e149
--- /dev/null
+++ b/www-apps/bareos-webui/files/postinstall-en.txt
@@ -0,0 +1,20 @@
+You need to configure
+
+ /etc/bareos-webui/directors.ini
+
+to point the webui to the right bareos director(s).
+
+The webui itself can be configured via
+
+ /etc/bareos-webui/configuration.ini
+
+NOTE: If you need to use different ini-files per vhost you can set
+ env BAREOS_WEBUI_CONFDIR in the webserver to point to another
+ directory than /etc/bareos-webui.
+
+To start using the Bareos Web User Interface, point your browser to
+
+ http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/
+ or
+ https://${VHOST_HOSTNAME}/${VHOST_APPDIR}/
+
diff --git a/www-apps/bareos-webui/metadata.xml b/www-apps/bareos-webui/metadata.xml
new file mode 100644
index 0000000..4a5a7ed
--- /dev/null
+++ b/www-apps/bareos-webui/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'http://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mschiff@gentoo.org</email>
+ <name>Marc Schiffbauer</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">bareos/bareos</remote-id>
+ </upstream>
+</pkgmetadata>