summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul de Vrieze <pauldv@gentoo.org>2009-01-09 20:40:16 +0000
committerPaul de Vrieze <pauldv@gentoo.org>2009-01-09 20:40:16 +0000
commite90a3c2db408b6afbfa1d910725569f3a02689e5 (patch)
tree7bffb257bdc7bbcad7d3fb1c2c50414044bbce5f
parentAdd computer modern fonts (diff)
downloadpauldv-e90a3c2db408b6afbfa1d910725569f3a02689e5.tar.gz
pauldv-e90a3c2db408b6afbfa1d910725569f3a02689e5.tar.bz2
pauldv-e90a3c2db408b6afbfa1d910725569f3a02689e5.zip
Add option to set the resolution for filter rendering from the command line, and increase the defaults to 150dpi
svn path=/trunk/overlay/; revision=81
-rw-r--r--media-gfx/inkscape/Manifest3
-rw-r--r--media-gfx/inkscape/files/inkscape-0.47-export-dpi.patch56
-rw-r--r--media-gfx/inkscape/inkscape-0.47_pre20479.ebuild1
3 files changed, 59 insertions, 1 deletions
diff --git a/media-gfx/inkscape/Manifest b/media-gfx/inkscape/Manifest
index bf2bc06..69968d9 100644
--- a/media-gfx/inkscape/Manifest
+++ b/media-gfx/inkscape/Manifest
@@ -1,6 +1,7 @@
AUX inkscape-0.47-escapeDevName.patch 1075 RMD160 bb01d422f1eb4ea7420681b4b25bb98fe27512bf SHA1 99783aa78e8564a300fa39663bd0580201fa912d SHA256 89e71ba4573b896389f567a2321b48b3e16a4eec3233a527bdf94806762fc40f
+AUX inkscape-0.47-export-dpi.patch 1921 RMD160 4d650ebc3518cddac3815c586a1fbd3fb20d64bf SHA1 7b3547966f6741ba1e170eef703e29fc71d9ba98 SHA256 31ef78f2a6d49a123bd12fdca85f90d68c800e942532609579eecdf3bd197e0c
AUX inkscape-0.47-type-punning.patch 440 RMD160 2eb47c48ec5017dc8e22582a06e817a8dce19aa5 SHA1 f78b90d499c72c0e98229d0de41018e50309582f SHA256 e3cbd6bd071f7525b55f6b0bdb72137d4ffa02eed6c490ad67943db564171636
EBUILD inkscape-0.47_pre20335.ebuild 3127 RMD160 f2078f72f8c3a790f7157c2ef1644e19514abf0b SHA1 498dfd4a5a06e34cfd53acb48b4f3caeb6ba80a7 SHA256 9ceab470afcadc24a2f703637f871e7360d9fe37cfd87a16eccd7dcecc83067a
EBUILD inkscape-0.47_pre20395.ebuild 3127 RMD160 f2078f72f8c3a790f7157c2ef1644e19514abf0b SHA1 498dfd4a5a06e34cfd53acb48b4f3caeb6ba80a7 SHA256 9ceab470afcadc24a2f703637f871e7360d9fe37cfd87a16eccd7dcecc83067a
-EBUILD inkscape-0.47_pre20479.ebuild 3153 RMD160 333ba575e7f5f46759ee68349a5f2cbb3ecdd0a4 SHA1 0d8cf981afcd27f893ba9f245fcf14aa8e286604 SHA256 7c290e4815fe0b25154eccf776563ad5ca372c5c2e3d975437bb76669a09e4df
+EBUILD inkscape-0.47_pre20479.ebuild 3196 RMD160 a44bcf5bf760d521455b689d60cf2a6532dd06b7 SHA1 a1730b785d60e8f99d3ec5db73ccf5380c6e5e08 SHA256 a47fb7ac2647b86e390757cc7ede30c84d581ff3547155428625e26e786926ca
MISC NOTES 56 RMD160 d48096e40f8f09e4901631591be3ba9efdefb62b SHA1 f1764ab40c496936f46f560625046181eb64fef1 SHA256 c630b8873c8eafc186770124e61c71f71428440c6a2e95dc86c158fd4a49d778
diff --git a/media-gfx/inkscape/files/inkscape-0.47-export-dpi.patch b/media-gfx/inkscape/files/inkscape-0.47-export-dpi.patch
new file mode 100644
index 0000000..8997261
--- /dev/null
+++ b/media-gfx/inkscape/files/inkscape-0.47-export-dpi.patch
@@ -0,0 +1,56 @@
+Index: src/extension/internal/cairo-renderer-pdf-out.cpp
+===================================================================
+--- src/extension/internal/cairo-renderer-pdf-out.cpp (revision 20479)
++++ src/extension/internal/cairo-renderer-pdf-out.cpp (working copy)
+@@ -153,7 +153,7 @@
+ g_warning("Parameter <blurToBitmap> might not exist");
+ }
+
+- int new_bitmapResolution = 72;
++ int new_bitmapResolution = 150;
+ try {
+ new_bitmapResolution = mod->get_param_int("resolution");
+ }
+Index: src/extension/internal/cairo-ps-out.cpp
+===================================================================
+--- src/extension/internal/cairo-ps-out.cpp (revision 20479)
++++ src/extension/internal/cairo-ps-out.cpp (working copy)
+@@ -151,7 +151,7 @@
+ new_blurToBitmap = mod->get_param_bool("blurToBitmap");
+ } catch(...) {}
+
+- int new_bitmapResolution = 72;
++ int new_bitmapResolution = 150;
+ try {
+ new_bitmapResolution = mod->get_param_int("resolution");
+ } catch(...) {}
+@@ -215,7 +215,7 @@
+ new_blurToBitmap = mod->get_param_bool("blurToBitmap");
+ } catch(...) {}
+
+- int new_bitmapResolution = 72;
++ int new_bitmapResolution = 150;
+ try {
+ new_bitmapResolution = mod->get_param_int("resolution");
+ } catch(...) {}
+Index: src/main.cpp
+===================================================================
+--- src/main.cpp (revision 20479)
++++ src/main.cpp (working copy)
+@@ -1398,6 +1398,16 @@
+ (*i)->set_param_bool("blurToBitmap", TRUE);
+ }
+
++ if (sp_export_dpi) {
++ int dpi = atoi(sp_export_dpi);
++ if ((dpi < 1) || (dpi > 10000)) {
++ g_warning("DPI value %s out of range [1 - 10000]. Nothing exported.", sp_export_dpi);
++ return;
++ }
++ g_print("DPI: %d\n", dpi);
++ (*i)->set_param_int("resolution", dpi);
++ }
++
+ (*i)->save(doc, uri);
+ }
+
diff --git a/media-gfx/inkscape/inkscape-0.47_pre20479.ebuild b/media-gfx/inkscape/inkscape-0.47_pre20479.ebuild
index 794e049..53703e0 100644
--- a/media-gfx/inkscape/inkscape-0.47_pre20479.ebuild
+++ b/media-gfx/inkscape/inkscape-0.47_pre20479.ebuild
@@ -101,6 +101,7 @@ src_unpack() {
cd "${S}"
epatch ${FILESDIR}/${MP}-type-punning.patch
+ epatch ${FILESDIR}/${MP}-export-dpi.patch
sed -i -e "s,\(AC_INIT.*[0-9.]\++devel\),\1-r${PREVER}," configure.ac