summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/bison/bison-2.3-r1.ebuild')
-rw-r--r--sys-devel/bison/bison-2.3-r1.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/sys-devel/bison/bison-2.3-r1.ebuild b/sys-devel/bison/bison-2.3-r1.ebuild
deleted file mode 100644
index 547b333..0000000
--- a/sys-devel/bison/bison-2.3-r1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-2.3.ebuild,v 1.10 2007/12/27 19:29:06 vapier Exp $
-
-inherit toolchain-funcs flag-o-matic
-
-DESCRIPTION="A yacc-compatible parser generator"
-HOMEPAGE="http://www.gnu.org/software/bison/bison.html"
-SRC_URI="mirror://gnu/bison/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="nls static"
-
-DEPEND="nls? ( sys-devel/gettext )"
-
-RDEPEND="sys-devel/m4
- app-admin/eselect-yacc"
-
-src_compile() {
- use static && append-ldflags -static
- econf $(use_enable nls) || die
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- # This one is installed by dev-util/yacc
- mv "${D}"/usr/bin/yacc{,.bison} || die
-
- # We do not need this.
- rm -r "${D}"/usr/lib* || die
-
- dodoc AUTHORS NEWS ChangeLog README OChangeLog THANKS TODO
-}
-
-pkg_postinst() {
- "${ROOT}"/usr/bin/eselect yacc update
-}
-
-pkg_postrm() {
- "${ROOT}"/usr/bin/eselect yacc update
-}