summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libbash/libbash-0.1.ebuild')
-rw-r--r--dev-libs/libbash/libbash-0.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/libbash/libbash-0.1.ebuild b/dev-libs/libbash/libbash-0.1.ebuild
new file mode 100644
index 0000000..5bb57a6
--- /dev/null
+++ b/dev-libs/libbash/libbash-0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit java-pkg-opt-2
+
+DESCRIPTION="A C++ library for bash"
+HOMEPAGE="http://www.gentoo.org/proj/en/libbash/index.xml"
+SRC_URI="http://dev.gentoo.org/~qiaomuf/libbash-0.1.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="
+ dev-java/antlr:3[gunit]
+ >=dev-libs/antlr-c-3.3_pre20110403
+ >=dev-libs/boost-1.43.0
+ <sys-apps/paludis-0.62.0
+ >=sys-devel/gcc-4.5.1
+ doc? ( app-doc/doxygen
+ dev-texlive/texlive-latex )
+ test? ( >=virtual/jdk-1.4
+ dev-util/gtest )"
+
+RDEPEND=">=dev-libs/antlr-c-3.3_pre20110403"