summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/glib')
-rw-r--r--dev-libs/glib/Manifest9
-rw-r--r--dev-libs/glib/files/glib-2.10.3-ia64-atomic-ops.patch39
-rw-r--r--dev-libs/glib/files/glib-2.12.12-fbsd.patch21
-rw-r--r--dev-libs/glib/files/glib-2.18.1-workaround-gio-test-failure-without-userpriv.patch20
-rw-r--r--dev-libs/glib/files/glib-2.24-assert-test-failure.patch19
-rw-r--r--dev-libs/glib/files/glib-2.25-punt-python-check.patch20
-rw-r--r--dev-libs/glib/files/glib-2.25-skip-tests-with-dbus-keyring.patch22
-rw-r--r--dev-libs/glib/files/glib-2.6.3-testglib-ssp.patch11
-rw-r--r--dev-libs/glib/glib-2.27.4.ebuild135
9 files changed, 0 insertions, 296 deletions
diff --git a/dev-libs/glib/Manifest b/dev-libs/glib/Manifest
deleted file mode 100644
index a6dbffe..0000000
--- a/dev-libs/glib/Manifest
+++ /dev/null
@@ -1,9 +0,0 @@
-AUX glib-2.10.3-ia64-atomic-ops.patch 1058 RMD160 066e63a99739dc412fbed7f773118323f53ea774 SHA1 13c22e2f75a77e9e0546e495fd28015ddcb8bade SHA256 ad9cad6793626b4e36a59aa6cb839607847aa57ebc37592fd1e273ccd23a53c8
-AUX glib-2.12.12-fbsd.patch 668 RMD160 d8bf399b7e0b417c4622b278282086418c1d3363 SHA1 b7a0f4d67083f2c9b4bbecd84a6d597dd0f0f9ed SHA256 23b0dc406d3d45fe125268b731af67147e83f6e38a63c7892828bdbfe1c31e8d
-AUX glib-2.18.1-workaround-gio-test-failure-without-userpriv.patch 616 RMD160 dd06abe9298d6e3e4d3eda0d5d155f1545dfd1aa SHA1 92164aa1b29f49cf62fc366231f2046b8b3def52 SHA256 e64ad4fbd67f142f5a19b29eab323bf18856309ed064e7a9f838b6c1c38a8adb
-AUX glib-2.24-assert-test-failure.patch 724 RMD160 011da2b341281d14741e715eddd401968464608d SHA1 76149f52677a337569dbab1b5f664c8fc16d44ff SHA256 1e3d290455d6bbc3a4f69d7b8abdeb559a01c8cd30dc311641e1cb0b7f84c6af
-AUX glib-2.25-punt-python-check.patch 541 RMD160 93fe958f07c2e03abb3abf95eaa0273b0822d874 SHA1 a9b0b50847f00773254b55238785f65f516ff4ad SHA256 eea2b3a2692b93c98ff06b26b784a264391bc61f8434d101c30cb14802234a3e
-AUX glib-2.25-skip-tests-with-dbus-keyring.patch 933 RMD160 20eb4c83cffca42aca845dc74cc2a67803c5df6c SHA1 f845fa3cc991330aa3dcdfbec8426501261a8c70 SHA256 930cdfe8f3b46c20826057b5771f953172c97fed8b3e509f4fde13094ff1c251
-AUX glib-2.6.3-testglib-ssp.patch 344 RMD160 6709acf85c52e39553e2e5ee93637f7e9cc7eca6 SHA1 403b249a460a9700669e754a562fb6974f3d6898 SHA256 c2ece3d7b4533e3bfbe8100df5d0824176d9dfa0b18697a8919162956c8ebfa8
-DIST glib-2.27.4.tar.bz2 6876218 RMD160 f992d7a069ef8195696cc7c9778993cc0cfe0810 SHA1 4ffdd4dd8a9e4d6ffea5939edddbbc755aed6d0e SHA256 71367cbf45998f736d7998282bc62fdefe13544a2c8ca523d9e5e9cc212758e6
-EBUILD glib-2.27.4.ebuild 4396 RMD160 e7e17396129ee6bafe41b8b452e49cff05a3041a SHA1 0fd2a437624f50ce186d5b5a07bcd41b2d4f40ba SHA256 385d5adc658fc8ab2452d1437f3709d812c2316023b451824b6abfdaedb66e41
diff --git a/dev-libs/glib/files/glib-2.10.3-ia64-atomic-ops.patch b/dev-libs/glib/files/glib-2.10.3-ia64-atomic-ops.patch
deleted file mode 100644
index 0859e33..0000000
--- a/dev-libs/glib/files/glib-2.10.3-ia64-atomic-ops.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From Debian, this one is needed for gcc < 4.1...
-
---- glib-2.10.0/glib/gatomic.c 2006-02-24 14:02:51.000000000 +0000
-+++ glib-2.10.0/glib/gatomic.c 2006-03-06 18:12:06.000000000 +0000
-@@ -414,14 +414,14 @@
- g_atomic_int_exchange_and_add (volatile gint *atomic,
- gint val)
- {
-- return __sync_fetch_and_add (atomic, val);
-+ return __sync_fetch_and_add_si (atomic, val);
- }
-
- void
- g_atomic_int_add (volatile gint *atomic,
- gint val)
- {
-- __sync_fetch_and_add (atomic, val);
-+ __sync_fetch_and_add_si (atomic, val);
- }
-
- gboolean
-@@ -429,7 +429,7 @@
- gint oldval,
- gint newval)
- {
-- return __sync_bool_compare_and_swap (atomic, oldval, newval);
-+ return __sync_bool_compare_and_swap_si (atomic, oldval, newval);
- }
-
- gboolean
-@@ -437,7 +437,7 @@
- gpointer oldval,
- gpointer newval)
- {
-- return __sync_bool_compare_and_swap ((long *)atomic,
-+ return __sync_bool_compare_and_swap_di ((long *)atomic,
- (long)oldval, (long)newval);
- }
-
diff --git a/dev-libs/glib/files/glib-2.12.12-fbsd.patch b/dev-libs/glib/files/glib-2.12.12-fbsd.patch
deleted file mode 100644
index bba6329..0000000
--- a/dev-libs/glib/files/glib-2.12.12-fbsd.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --exclude-from=/home/dang/.scripts/diffrc -up -ruN glib-2.12.12.orig/gmodule/gmodule-dl.c glib-2.12.12/gmodule/gmodule-dl.c
---- glib-2.12.12.orig/gmodule/gmodule-dl.c 2007-05-01 19:12:40.000000000 -0400
-+++ glib-2.12.12/gmodule/gmodule-dl.c 2007-07-05 20:10:51.000000000 -0400
-@@ -106,6 +106,7 @@ _g_module_open (const gchar *file_name,
- static gpointer
- _g_module_self (void)
- {
-+#ifndef __FreeBSD__
- gpointer handle;
-
- /* to query symbols from the program itself, special link options
-@@ -117,6 +118,9 @@ _g_module_self (void)
- g_module_set_error (fetch_dlerror (TRUE));
-
- return handle;
-+#else
-+ return RTLD_DEFAULT;
-+#endif
- }
-
- static void
diff --git a/dev-libs/glib/files/glib-2.18.1-workaround-gio-test-failure-without-userpriv.patch b/dev-libs/glib/files/glib-2.18.1-workaround-gio-test-failure-without-userpriv.patch
deleted file mode 100644
index cabe56f..0000000
--- a/dev-libs/glib/files/glib-2.18.1-workaround-gio-test-failure-without-userpriv.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Temporary workaround for gio tests failure when ran without FEATURES=userpriv
-until upstream bug #552912 is fixed
-
---- gio/tests/live-g-file.c.orig 2008-09-25 05:44:12.848556034 +0300
-+++ gio/tests/live-g-file.c 2008-09-25 06:12:34.248726237 +0300
-@@ -769,11 +769,14 @@
- if (posix_compat)
- {
- /* target directory is not accessible (no execute flag) */
-+#if 0
-+/* Fails when ran as root */
- do_copy_move (root, item, TEST_DIR_NO_ACCESS,
- TEST_NO_ACCESS);
- /* target directory is readonly */
- do_copy_move (root, item, TEST_DIR_NO_WRITE,
- TEST_NO_ACCESS);
-+#endif
- }
- }
- }
diff --git a/dev-libs/glib/files/glib-2.24-assert-test-failure.patch b/dev-libs/glib/files/glib-2.24-assert-test-failure.patch
deleted file mode 100644
index 6d8e74f..0000000
--- a/dev-libs/glib/files/glib-2.24-assert-test-failure.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Tests fail when upgrading glib from 2.22 to 2.24 if sys-devel/gdb is installed
-because gdb is run on .libs/assert-msg-test before LD_LIBRARY_PATH is set. This
-causes gdb to use the system-wide glib instead, and fail on the test.
-
-This patch exports LD_LIBRARY_PATH before running gdb
-
-https://bugzilla.gnome.org/621368
-
----
---- tests/run-assert-msg-test.sh
-+++ tests/run-assert-msg-test.sh
-@@ -34,6 +34,7 @@ if [ -e ".libs/lt-$msg_test" ]; then
- msg_test="lt-$msg_test"
- fi
- echo_v "Running gdb on assert-msg-test"
-+export LD_LIBRARY_PATH="`dirname $PWD`/glib/.libs:$LD_LIBRARY_PATH"
- OUT=$(gdb --batch --ex run --ex "print (char*) __glib_assert_msg" .libs/$msg_test 2> $error_out) || \
- fail "failed to run gdb"
-
diff --git a/dev-libs/glib/files/glib-2.25-punt-python-check.patch b/dev-libs/glib/files/glib-2.25-punt-python-check.patch
deleted file mode 100644
index 077ebf4..0000000
--- a/dev-libs/glib/files/glib-2.25-punt-python-check.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Remove python detection from configure.in, we won't be installing the gdb python
-scripts anymore. They use a redhat-specific gdb module that has not been
-upstreamed yet.
-
-https://bugs.gentoo.org/291328
-https://bugzilla.gnome.org/623552
----
---- configure.ac
-+++ configure.ac
-@@ -379,10 +379,6 @@ if test "x$PERL_PATH" = x ; then
- fi
- AC_SUBST(PERL_PATH)
-
--# Need suitable python path for greport
--AM_PATH_PYTHON(2.4,,PYTHON="/usr/bin/env python2.4")
--
--
- dnl ***********************
- dnl *** Tests for iconv ***
- dnl ***********************
diff --git a/dev-libs/glib/files/glib-2.25-skip-tests-with-dbus-keyring.patch b/dev-libs/glib/files/glib-2.25-skip-tests-with-dbus-keyring.patch
deleted file mode 100644
index baca1ec..0000000
--- a/dev-libs/glib/files/glib-2.25-skip-tests-with-dbus-keyring.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- gio/tests/gdbus-peer.c.orig 2010-08-28 20:06:11.000000000 +0300
-+++ gio/tests/gdbus-peer.c 2010-08-28 20:06:21.000000000 +0300
-@@ -1448,7 +1448,7 @@
-
- g_test_add_func ("/gdbus/peer-to-peer", test_peer);
- g_test_add_func ("/gdbus/delayed-message-processing", delayed_message_processing);
-- g_test_add_func ("/gdbus/nonce-tcp", test_nonce_tcp);
-+ //g_test_add_func ("/gdbus/nonce-tcp", test_nonce_tcp);
- g_test_add_func ("/gdbus/credentials", test_credentials);
- g_test_add_func ("/gdbus/overflow", test_overflow);
-
---- gio/tests/gdbus-non-socket.c.orig 2010-08-28 20:36:52.000000000 +0300
-+++ gio/tests/gdbus-non-socket.c 2010-08-28 20:37:02.000000000 +0300
-@@ -336,7 +336,7 @@
- /* all the tests rely on a shared main loop */
- loop = g_main_loop_new (NULL, FALSE);
-
-- g_test_add_func ("/gdbus/non-socket", test_non_socket);
-+ //g_test_add_func ("/gdbus/non-socket", test_non_socket);
-
- ret = g_test_run();
-
diff --git a/dev-libs/glib/files/glib-2.6.3-testglib-ssp.patch b/dev-libs/glib/files/glib-2.6.3-testglib-ssp.patch
deleted file mode 100644
index 9b104dd..0000000
--- a/dev-libs/glib/files/glib-2.6.3-testglib-ssp.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- tests/Makefile.in.orig 2005-04-07 01:05:39.000000000 +0000
-+++ tests/Makefile.in 2005-04-07 01:09:02.000000000 +0000
-@@ -50,7 +50,7 @@
- CATOBJEXT = @CATOBJEXT@
- CC = @CC@
- CCDEPMODE = @CCDEPMODE@
--CFLAGS = @CFLAGS@
-+CFLAGS = @CFLAGS@ -fno-stack-protector
- CPP = @CPP@
- CPPFLAGS = @CPPFLAGS@
- CROSS_COMPILING_FALSE = @CROSS_COMPILING_FALSE@
diff --git a/dev-libs/glib/glib-2.27.4.ebuild b/dev-libs/glib/glib-2.27.4.ebuild
deleted file mode 100644
index 65e497b..0000000
--- a/dev-libs/glib/glib-2.27.4.ebuild
+++ /dev/null
@@ -1,135 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="2"
-
-inherit autotools gnome.org libtool eutils flag-o-matic
-
-DESCRIPTION="The GLib library of C routines"
-HOMEPAGE="http://www.gtk.org/"
-
-LICENSE="LGPL-2"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="debug doc fam hardened +introspection selinux static-libs test xattr"
-
-# Due to removal of gio API, gnome bug 631398, tests will fail with:
-# symbol lookup error: /usr/lib64/gio/modules/libgiogconf.so: undefined symbol: g_desktop_app_info_lookup_get_type
-# That library is installed by gvfs, gvfs-1.6.4-r99* has a patch to remove it
-RDEPEND="virtual/libiconv
- sys-libs/zlib
- xattr? ( sys-apps/attr )
- fam? ( virtual/fam )"
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.16
- >=sys-devel/gettext-0.11
- doc? (
- >=dev-libs/libxslt-1.0
- >=dev-util/gtk-doc-1.11
- ~app-text/docbook-xml-dtd-4.1.2 )
- test? ( >=sys-apps/dbus-1.2.14 )"
-PDEPEND="introspection? ( dev-libs/gobject-introspection )
- !<gnome-base/gvfs-1.6.4-r990" # Earlier versions do not work with glib
-# XXX: Consider adding test? ( sys-devel/gdb ); assert-msg-test tries to use it
-
-src_prepare() {
- if use ia64 ; then
- # Only apply for < 4.1
- local major=$(gcc-major-version)
- local minor=$(gcc-minor-version)
- if (( major < 4 || ( major == 4 && minor == 0 ) )); then
- epatch "${FILESDIR}/glib-2.10.3-ia64-atomic-ops.patch"
- fi
- fi
-
- # Don't fail gio tests when ran without userpriv, upstream bug 552912
- # This is only a temporary workaround, remove as soon as possible
- epatch "${FILESDIR}/${PN}-2.18.1-workaround-gio-test-failure-without-userpriv.patch"
-
- # Fix gmodule issues on fbsd; bug #184301
- epatch "${FILESDIR}"/${PN}-2.12.12-fbsd.patch
-
- # Don't check for python, hence removing the build-time python dep.
- # We remove the gdb python scripts in src_install due to bug 291328
- epatch "${FILESDIR}/${PN}-2.25-punt-python-check.patch"
-
- # Fix test failure when upgrading from 2.22 to 2.24, upstream bug 621368
- epatch "${FILESDIR}/${PN}-2.24-assert-test-failure.patch"
-
- # skip tests that require writing to /root/.dbus, upstream bug 631379
- #epatch "${FILESDIR}/${PN}-2.25-skip-tests-with-dbus-keyring.patch"
-
- # Do not try to remove files on live filesystem, upstream bug #619274
- sed 's:^\(.*"/desktop-app-info/delete".*\):/*\1*/:' \
- -i "${S}"/gio/tests/desktop-app-info.c || die "sed failed"
-
- # Needed for the punt-python-check patch.
- eautoreconf
-
- [[ ${CHOST} == *-freebsd* ]] && elibtoolize
-
- epunt_cxx
-}
-
-src_configure() {
- local myconf
-
- # Building with --disable-debug highly unrecommended. It will build glib in
- # an unusable form as it disables some commonly used API. Please do not
- # convert this to the use_enable form, as it results in a broken build.
- # -- compnerd (3/27/06)
- use debug && myconf="--enable-debug"
-
- # Always use internal libpcre, bug #254659
- econf ${myconf} \
- $(use_enable xattr) \
- $(use_enable doc man) \
- $(use_enable doc gtk-doc) \
- $(use_enable fam) \
- $(use_enable selinux) \
- $(use_enable static-libs static) \
- --enable-regex \
- --with-pcre=internal \
- --with-threads=posix
-}
-
-src_install() {
- local f
- emake DESTDIR="${D}" install || die "Installation failed"
-
- # Do not install charset.alias even if generated, leave it to libiconv
- rm -f "${D}/usr/lib/charset.alias"
-
- # Don't install gdb python macros, bug 291328
- rm -rf "${D}/usr/share/gdb/" "${D}/usr/share/glib-2.0/gdb/"
-
- dodoc AUTHORS ChangeLog* NEWS* README || die "dodoc failed"
-
- insinto /usr/share/bash-completion
- for f in gdbus gsettings; do
- newins "${D}/etc/bash_completion.d/${f}-bash-completion.sh" ${f} || die
- done
- rm -rf "${D}/etc"
-}
-
-src_test() {
- unset DBUS_SESSION_BUS_ADDRESS
- export XDG_CONFIG_DIRS=/etc/xdg
- export XDG_DATA_DIRS=/usr/local/share:/usr/share
- export XDG_DATA_HOME="${T}"
- emake check || die "tests failed"
-}
-
-pkg_preinst() {
- # Only give the introspection message if:
- # * The user has it enabled
- # * Has glib already installed
- # * Previous version was different from new version
- if use introspection && has_version "${CATEGORY}/${PN}"; then
- if ! has_version "=${CATEGORY}/${PF}"; then
- ewarn "You must rebuild gobject-introspection so that the installed"
- ewarn "typelibs and girs are regenerated for the new APIs in glib"
- fi
- fi
-}