summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-filter/sbd-proxy/sbd-proxy-1.2-r1.ebuild')
-rw-r--r--mail-filter/sbd-proxy/sbd-proxy-1.2-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/mail-filter/sbd-proxy/sbd-proxy-1.2-r1.ebuild b/mail-filter/sbd-proxy/sbd-proxy-1.2-r1.ebuild
new file mode 100644
index 0000000..0145da2
--- /dev/null
+++ b/mail-filter/sbd-proxy/sbd-proxy-1.2-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils user
+
+DESCRIPTION="An SMTP proxy for solicited bounce detection"
+HOMEPAGE="http://dev.gentoo.org/~wschlich/"
+SRC_URI="http://dev.gentoo.org/~wschlich/src/${CATEGORY}/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="
+ virtual/perl-Getopt-Long
+ virtual/perl-Sys-Syslog
+ dev-perl/Config-IniFiles
+ dev-perl/DBI
+ dev-perl/Exception-Class
+ dev-perl/Exception-Class-TryCatch
+ dev-perl/Exception-Class-DBI
+"
+RDEPEND="${DEPEND}
+ virtual/mysql
+"
+
+pkg_setup() {
+ enewgroup sbd
+ enewuser sbd -1 -1 -1 sbd
+}
+
+src_install(){
+ newinitd "${FILESDIR}"/${PN}.initd ${PN} || die
+ newconfd "${FILESDIR}"/${PN}.confd ${PN} || die
+ dobin ${PN}.pl || die
+ insopts -o sbd -g sbd -m 0640
+ insinto /etc
+ doins ${PN}.ini || die
+ dodoc sbd-proxy-setup-mysql.sql
+}
+
+pkg_postinst() {
+ einfo
+ einfo "See the bundled sbd-proxy-setup-mysql.sql example on"
+ einfo "how to create the needed MySQL database, user and table."
+ einfo
+}