summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/hub/hub-1.10.2.ebuild')
-rw-r--r--dev-vcs/hub/hub-1.10.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-vcs/hub/hub-1.10.2.ebuild b/dev-vcs/hub/hub-1.10.2.ebuild
new file mode 100644
index 0000000..0d08a33
--- /dev/null
+++ b/dev-vcs/hub/hub-1.10.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md HISTORY.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Wrapper for git that make working with GitHub easier"
+HOMEPAGE="http://defunkt.io/hub"
+SRC_URI="https://github.com/defunkt/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-vcs/git-1.7.3"
+RDEPEND="${DEPEND}"
+
+ruby_add_bdepend "test? (
+ dev-ruby/test-unit
+ dev-ruby/webmock
+ )"
+
+ruby_add_rdepend "app-text/ronn
+ dev-ruby/json
+ dev-ruby/sinatra
+ dev-util/aruba
+ www-servers/thin"
+
+all_ruby_prepare() {
+ # Remove bundler support.
+ rm Gemfile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/${PN}.1
+}