aboutsummaryrefslogtreecommitdiff
path: root/sim
diff options
context:
space:
mode:
authorNick Clifton <nickc@redhat.com>2008-07-29 13:53:02 +0000
committerNick Clifton <nickc@redhat.com>2008-07-29 13:53:02 +0000
commit086c6838fab1ebd605b03d14e4fbd7a31a86062d (patch)
treebc2f3401e007981506381e15cc53e570748a3f63 /sim
parent*** empty log message *** (diff)
downloadbinutils-gdb-086c6838fab1ebd605b03d14e4fbd7a31a86062d.tar.gz
binutils-gdb-086c6838fab1ebd605b03d14e4fbd7a31a86062d.tar.bz2
binutils-gdb-086c6838fab1ebd605b03d14e4fbd7a31a86062d.zip
* common/genmloop.sh: Add new parameter: -shell to specify the
command interpreter to use to run the input file. This is necessary because otherwise SHELL is taken from the user's environment, and not from the makefile that invoked this script and the user might not be running an sh-like shell. * cris/Makefile.in: Pass -shell parameter to genmloop.sh. * fr30/Makefile.in: Likewise. * frv/Makefile.in: Likewise. * i960/Makefile.in: Likewise. * iq2000/Makefile.in: Likewise. * m32r/Makefile.in: Likewise. * frv/mloop.in: Add missing start of line comment marker.
Diffstat (limited to 'sim')
-rw-r--r--sim/ChangeLog16
-rw-r--r--sim/common/genmloop.sh5
-rw-r--r--sim/cris/Makefile.in4
-rw-r--r--sim/frv/Makefile.in2
-rw-r--r--sim/frv/mloop.in2
-rw-r--r--sim/iq2000/Makefile.in2
-rw-r--r--sim/m32r/Makefile.in6
7 files changed, 29 insertions, 8 deletions
diff --git a/sim/ChangeLog b/sim/ChangeLog
index 4e9d167b644..0b8128b376a 100644
--- a/sim/ChangeLog
+++ b/sim/ChangeLog
@@ -1,3 +1,19 @@
+2008-07-29 Nick Clifton <nickc@redhat.com>
+
+ * common/genmloop.sh: Add new parameter: -shell to specify the
+ command interpreter to use to run the input file. This is
+ necessary because otherwise SHELL is taken from the user's
+ environment, and not from the makefile that invoked this script
+ and the user might not be running an sh-like shell.
+ * cris/Makefile.in: Pass -shell parameter to genmloop.sh.
+ * fr30/Makefile.in: Likewise.
+ * frv/Makefile.in: Likewise.
+ * i960/Makefile.in: Likewise.
+ * iq2000/Makefile.in: Likewise.
+ * m32r/Makefile.in: Likewise.
+
+ * frv/mloop.in: Add missing start of line comment marker.
+
2008-07-11 Hans-Peter Nilsson <hp@axis.com>
* cris/configure: Regenerate to track ../common/common.m4 changes.
diff --git a/sim/common/genmloop.sh b/sim/common/genmloop.sh
index 88bd16d0fe9..58c2ff98af0 100644
--- a/sim/common/genmloop.sh
+++ b/sim/common/genmloop.sh
@@ -118,6 +118,10 @@
#
# Specify the suffix to append to output files.
#
+# -shell <shell>
+#
+# Specify the shell to use to execute <input-file>
+#
# Only one of -scache/-pbb may be selected.
# -simple is the default.
#
@@ -160,6 +164,7 @@ do
-switch) shift ; switch=$1 ;;
-cpu) shift ; cpu=$1 ;;
-infile) shift ; infile=$1 ;;
+ -shell) shift ; SHELL=$1 ;;
*) echo "unknown option: $1" >&2 ; exit 1 ;;
esac
shift
diff --git a/sim/cris/Makefile.in b/sim/cris/Makefile.in
index 02961a05145..6f7811f8ffc 100644
--- a/sim/cris/Makefile.in
+++ b/sim/cris/Makefile.in
@@ -95,7 +95,7 @@ crisv10f.o: crisv10f.c cris-tmpl.c $(CRISV10F_INCLUDE_DEPS)
# than the apparent; some "mono" feature is work in progress)?
mloopv10f.c engv10.h: stamp-v10fmloop
stamp-v10fmloop: $(srcdir)/../common/genmloop.sh mloop.in Makefile
- $(SHELL) $(srccom)/genmloop.sh \
+ $(SHELL) $(srccom)/genmloop.sh -shell $(SHELL) \
-mono -no-fast -pbb -switch semcrisv10f-switch.c \
-cpu crisv10f -infile $(srcdir)/mloop.in
$(SHELL) $(srcroot)/move-if-change eng.hin engv10.h
@@ -121,7 +121,7 @@ mloopv32f.c engv32.h: stamp-v32fmloop
# We depend on stamp-v10fmloop to get serialization to avoid
# racing with it for the same temporary file-names when "make -j".
stamp-v32fmloop: stamp-v10fmloop $(srcdir)/../common/genmloop.sh mloop.in Makefile
- $(SHELL) $(srccom)/genmloop.sh \
+ $(SHELL) $(srccom)/genmloop.sh -shell $(SHELL) \
-mono -no-fast -pbb -switch semcrisv32f-switch.c \
-cpu crisv32f -infile $(srcdir)/mloop.in
$(SHELL) $(srcroot)/move-if-change eng.hin engv32.h
diff --git a/sim/frv/Makefile.in b/sim/frv/Makefile.in
index db4c603f308..046902ed2c6 100644
--- a/sim/frv/Makefile.in
+++ b/sim/frv/Makefile.in
@@ -89,7 +89,7 @@ sim-if.o: sim-if.c $(FRVBF_INCLUDE_DEPS) $(srcdir)/../common/sim-core.h eng.h
# FIXME: Use of `mono' is wip.
mloop.c eng.h: stamp-mloop
stamp-mloop: $(srcdir)/../common/genmloop.sh mloop.in Makefile
- $(SHELL) $(srccom)/genmloop.sh \
+ $(SHELL) $(srccom)/genmloop.sh -shell $(SHELL) \
-mono -scache -parallel-generic-write -parallel-only \
-cpu frvbf -infile $(srcdir)/mloop.in
$(SHELL) $(srcroot)/move-if-change eng.hin eng.h
diff --git a/sim/frv/mloop.in b/sim/frv/mloop.in
index 3afe3b95c52..e679fa7322f 100644
--- a/sim/frv/mloop.in
+++ b/sim/frv/mloop.in
@@ -1,6 +1,6 @@
# Simulator main loop for frv. -*- C -*-
# Copyright (C) 1998, 1999, 2000, 2001, 2003, 2007, 2008
- Free Software Foundation, Inc.
+# Free Software Foundation, Inc.
# Contributed by Red Hat.
#
# This file is part of the GNU Simulators.
diff --git a/sim/iq2000/Makefile.in b/sim/iq2000/Makefile.in
index 7b60319b1a0..7048cf581af 100644
--- a/sim/iq2000/Makefile.in
+++ b/sim/iq2000/Makefile.in
@@ -69,7 +69,7 @@ iq2000.o: $(srcdir)/iq2000.c $(IQ2000BF_INCLUDE_DEPS)
# FIXME: Use of `mono' is wip.
mloop.c eng.h: stamp-mloop
stamp-mloop: $(srcdir)/../common/genmloop.sh mloop.in Makefile
- $(SHELL) $(srccom)/genmloop.sh \
+ $(SHELL) $(srccom)/genmloop.sh -shell $(SHELL) \
-mono -fast -pbb -switch sem-switch.c \
-cpu iq2000bf -infile $(srcdir)/mloop.in
$(SHELL) $(srcroot)/move-if-change eng.hin eng.h
diff --git a/sim/m32r/Makefile.in b/sim/m32r/Makefile.in
index 148b8ba22cb..f63cc4cc379 100644
--- a/sim/m32r/Makefile.in
+++ b/sim/m32r/Makefile.in
@@ -81,7 +81,7 @@ m32r.o: m32r.c $(M32RBF_INCLUDE_DEPS)
# FIXME: Use of `mono' is wip.
mloop.c eng.h: stamp-mloop
stamp-mloop: $(srcdir)/../common/genmloop.sh mloop.in Makefile
- $(SHELL) $(srccom)/genmloop.sh \
+ $(SHELL) $(srccom)/genmloop.sh -shell $(SHELL) \
-mono -fast -pbb -switch sem-switch.c \
-cpu m32rbf -infile $(srcdir)/mloop.in
$(SHELL) $(srcroot)/move-if-change eng.hin eng.h
@@ -105,7 +105,7 @@ m32rx.o: m32rx.c $(M32RXF_INCLUDE_DEPS)
# FIXME: Use of `mono' is wip.
mloopx.c engx.h: stamp-xmloop
stamp-xmloop: $(srcdir)/../common/genmloop.sh mloopx.in Makefile
- $(SHELL) $(srccom)/genmloop.sh \
+ $(SHELL) $(srccom)/genmloop.sh -shell $(SHELL) \
-mono -no-fast -pbb -parallel-write -switch semx-switch.c \
-cpu m32rxf -infile $(srcdir)/mloopx.in \
-outfile-suffix x
@@ -130,7 +130,7 @@ m32r2.o: m32r2.c $(M32R2F_INCLUDE_DEPS)
# FIXME: Use of `mono' is wip.
mloop2.c eng2.h: stamp-2mloop
stamp-2mloop: $(srcdir)/../common/genmloop.sh mloop2.in Makefile
- $(SHELL) $(srccom)/genmloop.sh \
+ $(SHELL) $(srccom)/genmloop.sh -shell $(SHELL) \
-mono -no-fast -pbb -parallel-write -switch sem2-switch.c \
-cpu m32r2f -infile $(srcdir)/mloop2.in \
-outfile-suffix 2