aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Stinner <vstinner@python.org>2021-01-19 23:04:49 +0100
committerGitHub <noreply@github.com>2021-01-19 23:04:49 +0100
commitcad8020cb83ec6d904f874c0e4f599e651022196 (patch)
tree7db4f105af783ecd5ac60488b081d945bcea14b3 /PCbuild
parentbpo-41713: Remove PyOS_InitInterrupts() from python3dll.c (GH-24257) (diff)
downloadcpython-cad8020cb83ec6d904f874c0e4f599e651022196.tar.gz
cpython-cad8020cb83ec6d904f874c0e4f599e651022196.tar.bz2
cpython-cad8020cb83ec6d904f874c0e4f599e651022196.zip
bpo-42955: Add Python/module_names.h (GH-24258)
Add a private list of all stdlib modules: _Py_module_names. * Add Tools/scripts/generate_module_names.py script. * Makefile: Add "make regen-module-names" command. * setup.py: Add --list-module-names option. * GitHub Action and Travis CI also runs "make regen-module-names", not ony "make regen-all", to ensure that the module names remains up to date.
Diffstat (limited to 'PCbuild')
-rw-r--r--PCbuild/pythoncore.vcxproj1
-rw-r--r--PCbuild/pythoncore.vcxproj.filters3
2 files changed, 4 insertions, 0 deletions
diff --git a/PCbuild/pythoncore.vcxproj b/PCbuild/pythoncore.vcxproj
index fd27dea9dae..6a260da6555 100644
--- a/PCbuild/pythoncore.vcxproj
+++ b/PCbuild/pythoncore.vcxproj
@@ -291,6 +291,7 @@
<ClInclude Include="..\Python\ceval_gil.h" />
<ClInclude Include="..\Python\condvar.h" />
<ClInclude Include="..\Python\importdl.h" />
+ <ClInclude Include="..\Python\module_names.h" />
<ClInclude Include="..\Python\thread_nt.h" />
<ClInclude Include="..\Python\wordcode_helpers.h" />
</ItemGroup>
diff --git a/PCbuild/pythoncore.vcxproj.filters b/PCbuild/pythoncore.vcxproj.filters
index 75a653dcbda..98e3ca2c9e6 100644
--- a/PCbuild/pythoncore.vcxproj.filters
+++ b/PCbuild/pythoncore.vcxproj.filters
@@ -360,6 +360,9 @@
<ClInclude Include="..\Python\importdl.h">
<Filter>Python</Filter>
</ClInclude>
+ <ClInclude Include="..\Python\module_names.h">
+ <Filter>Python</Filter>
+ </ClInclude>
<ClInclude Include="..\Python\thread_nt.h">
<Filter>Python</Filter>
</ClInclude>