aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZackery Spytz <zspytz@gmail.com>2020-04-09 06:03:49 -0600
committerGitHub <noreply@github.com>2020-04-09 13:03:49 +0100
commit97e0de04b8cd44474e452a028761e34407192041 (patch)
treec9041db6144355b0e2c1573a21dae089a6b4e4c6 /configure.ac
parentbpo-40082: trip_signal() uses the main interpreter (GH-19441) (diff)
downloadcpython-97e0de04b8cd44474e452a028761e34407192041.tar.gz
cpython-97e0de04b8cd44474e452a028761e34407192041.tar.bz2
cpython-97e0de04b8cd44474e452a028761e34407192041.zip
bpo-25780: Expose CAN_RAW_JOIN_FILTERS in the socket module (GH-19190)
Co-Authored-By: Stefan Tatschner <stefan@rumpelsepp.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8eed0151ebb..6bc8499f7ff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3447,6 +3447,16 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ /* CAN_RAW_FD_FRAMES available check */
AC_MSG_RESULT(no)
])
+AC_MSG_CHECKING(for CAN_RAW_JOIN_FILTERS)
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+#include <linux/can/raw.h>]],
+[[int can_raw_join_filters = CAN_RAW_JOIN_FILTERS;]])],[
+ AC_DEFINE(HAVE_LINUX_CAN_RAW_JOIN_FILTERS, 1, [Define if compiling using Linux 4.1 or later.])
+ AC_MSG_RESULT(yes)
+],[
+ AC_MSG_RESULT(no)
+])
+
# Check for --with-doc-strings
AC_MSG_CHECKING(for --with-doc-strings)
AC_ARG_WITH(doc-strings,