aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin Adler <kadler@us.ibm.com>2020-11-16 09:16:10 -0600
committerGitHub <noreply@github.com>2020-11-16 16:16:10 +0100
commitc79667ff7921444911e8a5dfa5fba89294915590 (patch)
tree507ad56a5b4cb66d08c7aeb9c20c7389d250bf9b /configure.ac
parentbpo-37205: time.time() cannot fail with fatal error (GH-23314) (diff)
downloadcpython-c79667ff7921444911e8a5dfa5fba89294915590.tar.gz
cpython-c79667ff7921444911e8a5dfa5fba89294915590.tar.bz2
cpython-c79667ff7921444911e8a5dfa5fba89294915590.zip
bpo-42087: Remove support for AIX 5.3 and below (GH-22830)
As AIX 5.3 and below do not support thread_cputime, it was decided in https://bugs.python.org/issue40680 to require AIX 6.1 and above. This commit removes workarounds for — and references to — older, unsupported AIX versions.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 2 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index e499cb4da0..440cdd178e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -512,16 +512,6 @@ case $ac_sys_system/$ac_sys_release in
define_xopen_source=no;;
Darwin/@<:@[12]@:>@@<:@0-9@:>@.*)
define_xopen_source=no;;
- # On AIX 4 and 5.1, mbstate_t is defined only when _XOPEN_SOURCE == 500 but
- # used in wcsnrtombs() and mbsnrtowcs() even if _XOPEN_SOURCE is not defined
- # or has another value. By not (re)defining it, the defaults come in place.
- AIX/4)
- define_xopen_source=no;;
- AIX/5)
- if test `uname -r` -eq 1; then
- define_xopen_source=no
- fi
- ;;
# On QNX 6.3.2, defining _XOPEN_SOURCE prevents netdb.h from
# defining NI_NUMERICHOST.
QNX/6.3.2)
@@ -1048,10 +1038,7 @@ AC_MSG_CHECKING(EXPORTSYMS)
case $ac_sys_system in
AIX*)
EXPORTSYMS="Modules/python.exp"
- if test $ac_sys_release -ge 5 -o \
- $ac_sys_release -eq 4 -a `uname -r` -ge 2 ; then
- EXPORTSFROM=. # the main executable
- fi
+ EXPORTSFROM=. # the main executable
;;
esac
AC_MSG_RESULT($EXPORTSYMS)
@@ -3631,7 +3618,7 @@ AC_SUBST(DLINCLDIR)
DLINCLDIR=.
# the dlopen() function means we might want to use dynload_shlib.o. some
-# platforms, such as AIX, have dlopen(), but don't want to use it.
+# platforms have dlopen(), but don't want to use it.
AC_CHECK_FUNCS(dlopen)
# DYNLOADFILE specifies which dynload_*.o file we will use for dynamic