aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Ganssle <paul@ganssle.io>2020-05-16 04:20:06 -0400
committerGitHub <noreply@github.com>2020-05-16 10:20:06 +0200
commit62972d9d73e83d6eea157617cc69500ffec9e3f0 (patch)
treebd6ddda94be33d9803087398008d46b6cb370adb /setup.py
parentbpo-40457: Support OpenSSL without TLS 1.0/1.1 (GH-19862) (diff)
downloadcpython-62972d9d73e83d6eea157617cc69500ffec9e3f0.tar.gz
cpython-62972d9d73e83d6eea157617cc69500ffec9e3f0.tar.bz2
cpython-62972d9d73e83d6eea157617cc69500ffec9e3f0.zip
bpo-40503: PEP 615: Tests and implementation for zoneinfo (GH-19909)
This is the initial implementation of PEP 615, the zoneinfo module, ported from the standalone reference implementation (see https://www.python.org/dev/peps/pep-0615/#reference-implementation for a link, which has a more detailed commit history). This includes (hopefully) all functional elements described in the PEP, but documentation is found in a separate PR. This includes: 1. A pure python implementation of the ZoneInfo class 2. A C accelerated implementation of the ZoneInfo class 3. Tests with 100% branch coverage for the Python code (though C code coverage is less than 100%). 4. A compile-time configuration option on Linux (though not on Windows) Differences from the reference implementation: - The module is arranged slightly differently: the accelerated module is `_zoneinfo` rather than `zoneinfo._czoneinfo`, which also necessitates some changes in the test support function. (Suggested by Victor Stinner and Steve Dower.) - The tests are arranged slightly differently and do not include the property tests. The tests live at test/test_zoneinfo/test_zoneinfo.py rather than test/test_zoneinfo.py or test/test_zoneinfo/__init__.py because we may do some refactoring in the future that would likely require this separation anyway; we may: - include the property tests - automatically run all the tests against both pure Python and C, rather than manually constructing C and Python test classes (similar to the way this works with test_datetime.py, which generates C and Python test cases from datetimetester.py). - This includes a compile-time configuration option on Linux (though not on Windows); added with much help from Thomas Wouters. - Integration into the CPython build system is obviously different from building a standalone zoneinfo module wheel. - This includes configuration to install the tzdata package as part of CI, though only on the coverage jobs. Introducing a PyPI dependency as part of the CI build was controversial, and this is seen as less of a major change, since the coverage jobs already depend on pip and PyPI. Additional changes that were introduced as part of this PR, most / all of which were backported to the reference implementation: - Fixed reference and memory leaks With much debugging help from Pablo Galindo - Added smoke tests ensuring that the C and Python modules are built The import machinery can be somewhat fragile, and the "seamlessly falls back to pure Python" nature of this module makes it so that a problem building the C extension or a failure to import the pure Python version might easily go unnoticed. - Adjustments to zoneinfo.__dir__ Suggested by Petr Viktorin. - Slight refactorings as suggested by Steve Dower. - Removed unnecessary if check on std_abbr Discovered this because of a missing line in branch coverage.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 14 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 794ba2f7662..68fc3120cc3 100644
--- a/setup.py
+++ b/setup.py
@@ -304,6 +304,17 @@ def find_library_file(compiler, libname, std_dirs, paths):
else:
assert False, "Internal error: Path not found in std_dirs or paths"
+def validate_tzpath():
+ base_tzpath = sysconfig.get_config_var('TZPATH')
+ if not base_tzpath:
+ return
+
+ tzpaths = base_tzpath.split(os.pathsep)
+ bad_paths = [tzpath for tzpath in tzpaths if not os.path.isabs(tzpath)]
+ if bad_paths:
+ raise ValueError('TZPATH must contain only absolute paths, '
+ + f'found:\n{tzpaths!r}\nwith invalid paths:\n'
+ + f'{bad_paths!r}')
def find_module_file(module, dirlist):
"""Find a module in a set of possible folders. If it is not found
@@ -816,6 +827,8 @@ class PyBuildExt(build_ext):
# uses modf().
self.add(Extension('_datetime', ['_datetimemodule.c'],
libraries=['m']))
+ # zoneinfo module
+ self.add(Extension('_zoneinfo', ['_zoneinfo.c'])),
# random number generator implemented in C
self.add(Extension("_random", ["_randommodule.c"],
extra_compile_args=['-DPy_BUILD_CORE_MODULE']))
@@ -2495,6 +2508,7 @@ def main():
ProcessPoolExecutor = None
sys.modules['concurrent.futures.process'] = DummyProcess
+ validate_tzpath()
# turn off warnings when deprecated modules are imported
import warnings