summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2012-05-18 17:36:48 +0900
committerBenda Xu <heroxbd@gentoo.org>2012-05-18 17:36:48 +0900
commitfb26a5c2df5e1fde31491ebeff69112712008353 (patch)
tree2f8414516404877c9df8e29df0c2b2536ab2bd5c /net-dialup
downloadandroid-fb26a5c2df5e1fde31491ebeff69112712008353.tar.gz
android-fb26a5c2df5e1fde31491ebeff69112712008353.tar.bz2
android-fb26a5c2df5e1fde31491ebeff69112712008353.zip
initial commit
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/slirp/Manifest7
-rw-r--r--net-dialup/slirp/files/slirp-1.0.17-destdir.patch27
-rw-r--r--net-dialup/slirp/files/slirp-1.0.17-fullbolt.patch12
-rw-r--r--net-dialup/slirp/files/slirp-1.0.17-perl.patch15
-rw-r--r--net-dialup/slirp/slirp-1.0.17.ebuild55
5 files changed, 116 insertions, 0 deletions
diff --git a/net-dialup/slirp/Manifest b/net-dialup/slirp/Manifest
new file mode 100644
index 0000000..f25a9b3
--- /dev/null
+++ b/net-dialup/slirp/Manifest
@@ -0,0 +1,7 @@
+AUX slirp-1.0.17-destdir.patch 612 SHA1 2d4d5b050013e07df6cb4e1cc8881dec40103a60 SHA256 7383a8f7308a10718d4bf57a0a0d134bcd64d183361c82460f541fdfebb44934
+AUX slirp-1.0.17-fullbolt.patch 479 SHA1 d584a9032a03c5779e56982bb36f75020d3dda94 SHA256 748c6632da9e9af00a19b3a540892252522f155bab28d333a4e4a50eb7ccec58
+AUX slirp-1.0.17-perl.patch 452 SHA1 418f3fb33f5de9747bee1e9ead9109eb71ad3d3f SHA256 13f5596baf6791e129a4b990b8508b883928dc0c0227ba89287690f9b3f15c5d
+DIST slirp_1.0.17-4.debian.tar.gz 13774 SHA1 b1bb2c184e67dcaa794540470d661bd0ceaa1395 SHA256 824915cf0575ccf22c8cf00fe970ced7aee01596bc9f82ce1cb75e6ef5f81570
+DIST slirp_1.0.17.orig.tar.gz 305754 SHA1 9b660f5365f1d9536d9171c1e0de490ab2232ec8 SHA256 afe59cd298075aa1b9eba5a5f7cf720597372b8b81657de529b2cd35a2a2bc2e
+EBUILD slirp-1.0.17.ebuild 1479 SHA1 3c79a4f150809c0a537058d4c98e67db69db82e0 SHA256 f84217a8e5f10516352be625b7d7f2f51c2a01536450d4979cdbe94e7cb9c76f
+MISC slirp-1.0.17.ebuild~ 915 SHA1 fa4abcd3cdd222e7865995f077d89055496b324c SHA256 344f81231bc93311e3654f0735ad6ab5f23ff709ed483032d9b3c222ea2e7a36
diff --git a/net-dialup/slirp/files/slirp-1.0.17-destdir.patch b/net-dialup/slirp/files/slirp-1.0.17-destdir.patch
new file mode 100644
index 0000000..71657a7
--- /dev/null
+++ b/net-dialup/slirp/files/slirp-1.0.17-destdir.patch
@@ -0,0 +1,27 @@
+diff --git a/Makefile.in b/Makefile.in
+index b0c1fc6..c21da84 100755
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -35,7 +35,7 @@ COMMON_H = config.h ${srcdir}/slirp.h
+
+ BINDIR = @prefix@/bin
+
+-MANDIR = @prefix@/man/man1
++MANDIR = @prefix@/share/man/man1
+
+ MANEXT = 1
+
+@@ -45,11 +45,10 @@ slirp: $(PROTO) $(OBJ)
+ $(CC) @LDFLAGS@ -o slirp $(OBJ) $(LIBS)
+
+ install: slirp install.man
+- strip slirp
+- cp slirp $(BINDIR)
++ install -D slirp $(DESTDIR)$(BINDIR)/slirp
+
+ install.man:
+- cp slirp.man $(MANDIR)/slirp.$(MANEXT)
++ install -D -m 644 slirp.man $(DESTDIR)$(MANDIR)/slirp.$(MANEXT)
+
+ objclean:
+ rm -f $(OBJ)
diff --git a/net-dialup/slirp/files/slirp-1.0.17-fullbolt.patch b/net-dialup/slirp/files/slirp-1.0.17-fullbolt.patch
new file mode 100644
index 0000000..879d456
--- /dev/null
+++ b/net-dialup/slirp/files/slirp-1.0.17-fullbolt.patch
@@ -0,0 +1,12 @@
+diff -Naurp slirp-1.0.17.old//config.h.in slirp-1.0.17/config.h.in
+--- slirp-1.0.17.old//config.h.in 2011-02-16 00:57:54.000000000 +0900
++++ slirp-1.0.17/config.h.in 2011-02-16 00:58:43.000000000 +0900
+@@ -30,7 +30,7 @@
+ /* pretty good job on single modems already, and seting this will make */
+ /* interactive sessions less responsive */
+ /* XXXXX Talk about having fast modem as unit 0 */
+-#undef FULL_BOLT
++#define FULL_BOLT
+
+ /*
+ * Define if you want slirp to use less CPU
diff --git a/net-dialup/slirp/files/slirp-1.0.17-perl.patch b/net-dialup/slirp/files/slirp-1.0.17-perl.patch
new file mode 100644
index 0000000..2ab80a3
--- /dev/null
+++ b/net-dialup/slirp/files/slirp-1.0.17-perl.patch
@@ -0,0 +1,15 @@
+# this is a fix for use with perl-5.12, where split no longer
+# affects @_ by default.
+
+diff -Naurp slirp-1.0.17.old/mkpro slirp-1.0.17/mkpro
+--- slirp-1.0.17.old/mkpro 2004-09-01 18:58:51.000000000 +0900
++++ slirp-1.0.17/mkpro 2011-02-15 22:09:37.000000000 +0900
+@@ -87,7 +87,7 @@ STATE0:
+ $1 =~ /([^\*]+)/; # Remove "*"
+ $type = $1;
+
+- $n = split(/,/);
++ $n = @_ = split /,/;
+ $nargs += $n;
+ goto STATE0 if ($nargs > $nargs_guess);
+
diff --git a/net-dialup/slirp/slirp-1.0.17.ebuild b/net-dialup/slirp/slirp-1.0.17.ebuild
new file mode 100644
index 0000000..61d19ae
--- /dev/null
+++ b/net-dialup/slirp/slirp-1.0.17.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Tiziano Müller
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit eutils
+
+DESCRIPTION="TCP/IP emulator which turns an ordinary shell account into a (C)SLIP/PPP account."
+HOMEPAGE="http://packages.qa.debian.org/s/slirp.html"
+SRC_URI="mirror://debian/pool/main/s/${PN}/${PN}_1.0.17.orig.tar.gz
+ mirror://debian/pool/main/s/${PN}/${PN}_1.0.17-4.debian.tar.gz"
+
+LICENSE="NEWLIB"
+SLOT="0"
+KEYWORDS="~amd64-linux"
+IUSE="+ppp"
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+
+ epatch \
+ "${WORKDIR}/debian/patches/001-update-man-fix-hyphens-as-minus.patch" \
+ "${WORKDIR}/debian/patches/002-fix-arguements.patch" \
+ "${WORKDIR}/debian/patches/003-socklen_t.patch" \
+ "${WORKDIR}/debian/patches/004-compilation-warnings.patch" \
+ "${WORKDIR}/debian/patches/005-use-snprintf.patch" \
+ "${WORKDIR}/debian/patches/006-changelog-1.0.17.patch" \
+ "${WORKDIR}/debian/patches/007-debian-changes.patch" \
+ "${WORKDIR}/debian/patches/008-slirp-amd64-log-crash.patch"
+
+ # We do not need extra src subdir
+ mv src/* ./ && rmdir src
+
+ epatch \
+ "${FILESDIR}/${P}-perl.patch" \
+ "${FILESDIR}/${P}-destdir.patch" \
+ "${FILESDIR}/${P}-fullbolt.patch"
+}
+
+src_configure() {
+ local myconf=""
+ use ppp || myconf="--disable-ppp"
+ econf {myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc ChangeLog CONTRIB README README.NEXT TODO docs/*
+ # newdoc ${WORKDIR}/README README-1.0.17
+}
+