summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2021-05-11 10:46:33 -0500
committerWilliam Hubbs <williamh@gentoo.org>2021-05-11 10:46:33 -0500
commit47686e5e438c57cd7ffc94b2d7f15abc03146442 (patch)
tree1440195481d6a5457eeb32ed4af1a03d7b4be7e5
parentfix PRETTY_NAME (diff)
downloadbaselayout-47686e5e438c57cd7ffc94b2d7f15abc03146442.tar.gz
baselayout-47686e5e438c57cd7ffc94b2d7f15abc03146442.tar.bz2
baselayout-47686e5e438c57cd7ffc94b2d7f15abc03146442.zip
create bin and sbin directories
Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index c0d7283e..0913ceb6 100644
--- a/Makefile
+++ b/Makefile
@@ -33,16 +33,20 @@ KEEP_DIRS-Linux += \
/sys \
/usr/src
KEEP_DIRS = $(KEEP_DIRS-$(OS)) \
+ /bin \
/boot \
/etc/profile.d \
/home \
/media \
/mnt \
- /proc \
/opt \
+ /proc \
/root \
+ /sbin \
+ /usr/bin \
/usr/local/bin \
/usr/local/sbin \
+ /usr/sbin \
/var/cache \
/var/empty \
/var/lib \
@@ -92,6 +96,9 @@ layout: layout-dirs layout-$(OS)
layout-usrmerge: layout
ifeq ($(OS),Linux)
+ rm -fr ${DESTDIR}/bin
+ rm -fr ${DESTDIR}/sbin
+ rm -fr ${DESTDIR}/usr/sbin
ln -snf usr/bin ${DESTDIR}/bin
ln -snf usr/sbin ${DESTDIR}/sbin
ln -snf bin ${DESTDIR}/usr/sbin