summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/opal/opal-2.4b.ebuild')
-rw-r--r--dev-lang/opal/opal-2.4b.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-lang/opal/opal-2.4b.ebuild b/dev-lang/opal/opal-2.4b.ebuild
new file mode 100644
index 0000000..feda431
--- /dev/null
+++ b/dev-lang/opal/opal-2.4b.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils
+
+MY_P=ocs-${PV}
+
+DESCRIPTION="OPAL functional programming language"
+HOMEPAGE="http://uebb.cs.tu-berlin.de/~opal/"
+SRC_URI="http://projects.uebb.tu-berlin.de/opal/trac/raw-attachment/wiki/OCS/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="X doc +tk +tcl"
+
+DEPEND="
+ >=sys-libs/ncurses-5.4-r5
+ >=sys-libs/readline-4.3-r5
+ >=dev-lang/tk-8.4.6-r1
+ <dev-lang/tcl-8.6
+ "
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ econf \
+ $(use_enable doc) \
+ $(use_enable doc dosfop) \
+ --enable-opalwin \
+ --enable-oasys \
+ --enable-dynamic \
+ --disable-absolute-pathes \
+ --prefix="${D}/usr"
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ # chmod: /var <-- Prevent access violation
+ addpredict /var
+ mkdir -p "${D}/usr/" || die
+
+ emake -j1 install
+
+ # Fix man folder location
+ if [[ -d "${D}"/usr/man/ ]]; then
+ dodir /usr/share/
+ mv "${D}"/usr/{,share/}man/ || die
+ fi
+}