summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-08-15 09:11:35 +0200
committerMichał Górny <mgorny@gentoo.org>2017-08-15 09:11:35 +0200
commit2e532c0afb904d63c70525fd387431c42cee6f82 (patch)
tree873d68f27321d36e14fbbeb2d93da46ad919e7f4
parentAdd application script, and a Makefile (diff)
downloadelt-patches-2e532c0afb904d63c70525fd387431c42cee6f82.tar.gz
elt-patches-2e532c0afb904d63c70525fd387431c42cee6f82.tar.bz2
elt-patches-2e532c0afb904d63c70525fd387431c42cee6f82.zip
Support substituting functions.sh path as well, to fix Prefix20170815
Bug: https://bugs.gentoo.org/627824
-rw-r--r--Makefile5
-rw-r--r--eltpatch.in2
2 files changed, 5 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 05a8b7e..90ddc87 100644
--- a/Makefile
+++ b/Makefile
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
DESTDIR =
-prefix = /usr
+rootprefix =
+gentoofuncs = $(rootprefix)/lib/gentoo/functions.sh
+prefix = $(rootprefix)/usr
bindir = $(prefix)/bin
libdirname = lib
datadir = $(prefix)/share
@@ -16,6 +18,7 @@ eltpatch: eltpatch.in
rm -f $@ $@.tmp
sed -e 's^@ELT_patchdir@^$(patchdir)^' \
-e 's^@ELT_libdir@^$(libdirname)^' \
+ -e 's^@ELT_gentoofuncs@^$(gentoofuncs)^' \
$< > $@.tmp
chmod +x $@.tmp
mv $@.tmp $@
diff --git a/eltpatch.in b/eltpatch.in
index 7dae4bb..a4e87d2 100644
--- a/eltpatch.in
+++ b/eltpatch.in
@@ -2,7 +2,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-source "/lib/gentoo/functions.sh" || exit 1
+source "@ELT_gentoofuncs@" || exit 1
die() {
eerror "${@}"