aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--pyproject.toml33
1 files changed, 33 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..fe2a6e7
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,33 @@
+[tool.tbump.version]
+current = "2.1.0"
+regex = '''
+ (?P<major>\d+)
+ \.
+ (?P<minor>\d+)
+ \.
+ (?P<patch>\d+)
+ '''
+
+[tool.tbump.git]
+message_template = "bump to {new_version}"
+tag_template = "{new_version}"
+
+[[tool.tbump.file]]
+src = "./VERSION"
+search = "{current_version}"
+
+[[tool.tbump.file]]
+src = "./VERSION"
+search = "{current_version}"
+
+[[tool.tbump.file]]
+src = "./ebuild-snippets.el"
+search = ";; Version: {current_version}"
+
+[[tool.tbump.file]]
+src = "./ebuild-snippets.el"
+search = "defconst ebuild-snippets-version \"{current_version}\""
+
+[[tool.tbump.before_commit]]
+name = "execute make all"
+cmd = "make all"