aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven 'sleipnir' Rebhan <odinshorse@googlemail.com>2009-03-12 20:17:18 +0000
committerSven 'sleipnir' Rebhan <odinshorse@googlemail.com>2009-03-12 20:17:18 +0000
commit64bf52fcb6a6da7c73fbe26b81d7fdf963b6be55 (patch)
tree326e2a97c9880080f25ee652c01bc0363bf932df /sys-apps
parentupstream gettext works fine with overlays(sleipnir's) libtool (diff)
downloadembedded-cross-64bf52fcb6a6da7c73fbe26b81d7fdf963b6be55.tar.gz
embedded-cross-64bf52fcb6a6da7c73fbe26b81d7fdf963b6be55.tar.bz2
embedded-cross-64bf52fcb6a6da7c73fbe26b81d7fdf963b6be55.zip
Cleanup of groff.
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/groff/groff-1.20.1-r1.ebuild26
1 files changed, 13 insertions, 13 deletions
diff --git a/sys-apps/groff/groff-1.20.1-r1.ebuild b/sys-apps/groff/groff-1.20.1-r1.ebuild
index fcd4dbb..d57b601 100644
--- a/sys-apps/groff/groff-1.20.1-r1.ebuild
+++ b/sys-apps/groff/groff-1.20.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.20.1-r1.ebuild,v 1.8 2009/02/14 18:15:35 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.20.1-r1.ebuild,v 1.9 2009/03/09 05:13:53 darkside Exp $
inherit eutils toolchain-funcs autotools
@@ -11,7 +11,7 @@ SRC_URI="mirror://gnu/groff/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha ~amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
+KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
IUSE="X linguas_ja"
DEPEND=">=sys-apps/texinfo-4.7-r1
@@ -26,18 +26,18 @@ DEPEND=">=sys-apps/texinfo-4.7-r1
pkg_setup()
{
- # The host groff version needs to be the same then what we try to emerge.
- if tc-is-cross-compiler ; then
- HOSTGROFF=$(groff -v | grep 'GNU groff version' | sed -e 's/GNU groff version //')
- if [ "${HOSTGROFF}" == "" ]; then
- die "Groff must be installed on host for cross-compiling!"
+ # The host groff version needs to be the same then what we try to emerge.
+ if tc-is-cross-compiler ; then
+ HOSTGROFF=$(groff -v | grep 'GNU groff version' | sed -e 's/GNU groff version //')
+ if [ "${HOSTGROFF}" == "" ]; then
+ die "Groff must be installed on host for cross-compiling!"
+ fi
+ if [ "${HOSTGROFF}" != "${PV}" ]; then
+ eerror "Groff version ${HOSTGROFF} is installed on your host,"
+ eerror "but version ${PV} is required for cross-compilation."
+ die "Can't crosscompile groff due to version mismatch."
+ fi
fi
- if [ "${HOSTGROFF}" != "${PV}" ]; then
- eerror "Groff version ${HOSTGROFF} is installed on your host,"
- eerror "but version ${PV} is required for cross-compilation."
- die "Can't crosscompile groff due to version mismatch."
- fi
- fi
}
src_unpack() {