aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 7894e74..74c132a 100644
--- a/Makefile
+++ b/Makefile
@@ -8,6 +8,14 @@ BINDIR = /usr/sbin/
SYSTEMD_TARGET = /usr/lib/systemd/system/
SYSTEMD_UNIT = systemd/fifo-cronolog@.service
+VERSION = $(shell awk -F'"' '/#define VERSION/{print $$2}' $(SRC) )
+DISTFILE_EXT = tar.gz
+DISTFILE = $(BIN)-$(VERSION).$(DISTFILE_EXT)
+
+dist:
+ if test -e $(DISTFILE) ; then echo "$(DISTFILE) already exists" ; exit 1 ; fi
+ git archive --format $(DISTFILE_EXT) --prefix $(BIN)-$(VERSION)/ v$(VERSION) >$(DISTFILE).tmp && mv $(DISTFILE).tmp $(DISTFILE)
+
all: $(BIN)
$(BIN): $(OBJ)