aboutsummaryrefslogtreecommitdiff
path: root/4.6.2
diff options
context:
space:
mode:
authorMagnus Granberg <zorry@gentoo.org>2011-12-07 19:29:04 +0000
committerMagnus Granberg <zorry@gentoo.org>2011-12-07 19:29:04 +0000
commit5b2e615d9f14bc73b7ee10cccd61a32eee062ef2 (patch)
tree59f2b226f3eeaefd2e0832eacddec77d081dff38 /4.6.2
parentadd x32 backport from gcc-4.7 from upstream (diff)
downloadgcc-patches-5b2e615d9f14bc73b7ee10cccd61a32eee062ef2.tar.gz
gcc-patches-5b2e615d9f14bc73b7ee10cccd61a32eee062ef2.tar.bz2
gcc-patches-5b2e615d9f14bc73b7ee10cccd61a32eee062ef2.zip
gcc-4.6.2 piepatchset bumped to 0.5.0
Diffstat (limited to '4.6.2')
-rw-r--r--4.6.2/pie/10_all_gcc45_configure.patch26
-rw-r--r--4.6.2/pie/11_all_gcc45_config.in.patch (renamed from 4.6.2/pie/11_all_gcc44_config.in.patch)8
-rw-r--r--4.6.2/pie/12_all_gcc46_Makefile.in.patch53
-rw-r--r--4.6.2/pie/30_all_gcc45_esp.h.patch (renamed from 4.6.2/pie/30_all_gcc44_esp.h.patch)22
-rw-r--r--4.6.2/pie/35_all_gcc46_config_crtbeginp.patch (renamed from 4.6.2/pie/35_all_gcc46_config_crtbegints.patch)16
-rw-r--r--4.6.2/pie/README.Changelog32
-rw-r--r--4.6.2/pie/README.history13
7 files changed, 103 insertions, 67 deletions
diff --git a/4.6.2/pie/10_all_gcc45_configure.patch b/4.6.2/pie/10_all_gcc45_configure.patch
index 39893f3..357e63a 100644
--- a/4.6.2/pie/10_all_gcc45_configure.patch
+++ b/4.6.2/pie/10_all_gcc45_configure.patch
@@ -1,10 +1,10 @@
-2010-05-25 Magnus Granberg <zorry@gentoo.org>, Anthony G. Basile <basile@opensource.dyc.edu>
+2011-12-07 Magnus Granberg <zorry@gentoo.org>, Anthony G. Basile <basile@opensource.dyc.edu>
* configure Add --enable-esp. Add-fno-stack-protector
to stage1_cflags.
* gcc/configure Add --enable-esp. Check -z now and -z relro.
Define ENABLE_ESP.
- Check if we support crtbeginTS and define ENABLE_CRTBEGINTS.
+ Check if we support crtbeginP and define ENABLE_CRTBEGINP.
* libmudflap/configure Add AC_SUBST enable_esp.
@@ -73,7 +73,7 @@
GGC
libgcc_visibility
+enable_esp
-+enable_crtbeginTS
++enable_crtbeginP
gcc_cv_readelf
gcc_cv_objdump
ORIGINAL_NM_FOR_TARGET
@@ -169,33 +169,33 @@
+ { (exit 1); exit 1; }; }
+fi
+
-+echo "$as_me:$LINENO: checking for crtbeginTS.o support" >&5
-+echo $ECHO_N "checking for crtbeginTS.o support... $ECHO_C" >&6
-+if test "${enable_crtbeginTS+set}" = set; then
++echo "$as_me:$LINENO: checking for crtbeginP.o support" >&5
++echo $ECHO_N "checking for crtbeginP.o support... $ECHO_C" >&6
++if test "${enable_crtbeginP+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+else
+
+if test x$enable_esp = xyes ; then
+ case "$target" in
+ ia64*-*-linux*)
-+ enable_crtbeginTS=no ;;
++ enable_crtbeginP=no ;;
+ *-*-linux*)
+ if test x$gcc_cv_ld_pie = xyes && test x$lt_cv_prog_compiler_static_works = xyes; then
-+ enable_crtbeginTS=yes
++ enable_crtbeginP=yes
+ fi
+ ;;
-+ *) enable_crtbeginTS=no ;;
++ *) enable_crtbeginP=no ;;
+ esac
+fi
+
+fi
-+echo "$as_me:$LINENO: result: $enable_crtbeginTS" >&5
-+echo "${ECHO_T}$enable_crtbeginTS" >&6
++echo "$as_me:$LINENO: result: $enable_crtbeginP" >&5
++echo "${ECHO_T}$enable_crtbeginP" >&6
+
-+if test x$enable_crtbeginTS = xyes; then
++if test x$enable_crtbeginP = xyes; then
+
+cat >>confdefs.h <<\_ACEOF
-+#define ENABLE_CRTBEGINTS 1
++#define ENABLE_CRTBEGINP 1
+_ACEOF
+
+fi
diff --git a/4.6.2/pie/11_all_gcc44_config.in.patch b/4.6.2/pie/11_all_gcc45_config.in.patch
index 3e49f03..489658f 100644
--- a/4.6.2/pie/11_all_gcc44_config.in.patch
+++ b/4.6.2/pie/11_all_gcc45_config.in.patch
@@ -1,6 +1,6 @@
-2010-05-24 Magnus Granberg <zorry@gentoo.org>
+2011-12-05 Magnus Granberg <zorry@gentoo.org>
- * gcc/config.in Add ENABLE_CRTBEGINTS and ENABLE_ESP
+ * gcc/config.in Add ENABLE_CRTBEGINP and ENABLE_ESP
--- gcc/config.in 2009-04-21 11:08:08.000000000 +0200
+++ gcc/config.in 2009-05-12 00:10:08.000000000 +0200
@@ -8,9 +8,9 @@
#endif
-+/* Define to 1 to enable crtbeginTS.o. */
++/* Define to 1 to enable crtbeginP.o. */
+#ifndef USED_FOR_TARGET
-+#undef ENABLE_CRTBEGINTS
++#undef ENABLE_CRTBEGINP
+#endif
+
+
diff --git a/4.6.2/pie/12_all_gcc46_Makefile.in.patch b/4.6.2/pie/12_all_gcc46_Makefile.in.patch
index b17c0be..8011793 100644
--- a/4.6.2/pie/12_all_gcc46_Makefile.in.patch
+++ b/4.6.2/pie/12_all_gcc46_Makefile.in.patch
@@ -1,11 +1,13 @@
-2011-01-01 Magnus Granberg <zorry@gentoo.org> Anthony G. Basile <basile@opensource.dyc.edu>
+2011-12-07 Magnus Granberg <zorry@gentoo.org> Anthony G. Basile <basile@opensource.dyc.edu>
- * Makefile.in We add -fno-stack-protector to BOOT_CFLAGS, LIBCFLAGS and LIBCXXFLAGS if enable_esp yes.
- * gcc/Makefile.in Add -fno-PIE. to CRTSTUFF_CFLAGS and ALL_CFLAGS if enable_esp yes
- Add crtbeginTS.o to EXTRA_PARTS if enable_crtbeginTS yes
- We add new file crtbeginTS.o if enable_crtbeginTS yes
- * libgcc/Makefile.in Add crtbeginTS.o to EXTRA_PARTS if enable_crtbeginTS yes
- We add new file crtbeginTS.o if enable_crtbeginTS yes
+ * Makefile.in We add -fno-stack-protector to BOOT_CFLAGS, LIBCFLAGS and
+ LIBCXXFLAGS if enable_esp yes.
+ * gcc/Makefile.in Add -fno-PIE. to CRTSTUFF_CFLAGS, ALL_CFLAGS and
+ ALL_CXXFLAGS if enable_esp yes
+ Add crtbeginP.o to EXTRA_PARTS if enable_crtbeginP yes
+ We add new file crtbeginP.o if enable_crtbeginP yes
+ * libgcc/Makefile.in Add crtbeginP.o to EXTRA_PARTS if enable_crtbeginP yes
+ We add new file crtbeginP.o if enable_crtbeginP yes
--- Makefile.in 2010-01-22 08:35:38.000000000 -0500
+++ Makefile.in 2010-02-07 15:10:59.000000000 -0500
@@ -70,16 +72,16 @@
# The rules for compiling them should be in the t-* file for the machine.
EXTRA_PARTS = @extra_parts@
-+# We add crtbeginTS.o to the EXTRA_PARTS list if enable_crtbeginTS = yes
-+enable_crtbeginTS = @enable_crtbeginTS@
-+ifeq ($(enable_crtbeginTS),yes)
-+EXTRA_PARTS += crtbeginTS.o
++# We add crtbeginP.o to the EXTRA_PARTS list if enable_crtbeginP = yes
++enable_crtbeginP = @enable_crtbeginP@
++ifeq ($(enable_crtbeginP),yes)
++EXTRA_PARTS += crtbeginP.o
+endif
+
# List of extra object files that should be compiled and linked with
# compiler proper (cc1, cc1obj, cc1plus).
EXTRA_OBJS = @extra_objs@
-@@ -998,7 +1006,7 @@
+@@ -1002,12 +1010,12 @@
# This is the variable actually used when we compile. If you change this,
# you probably want to update BUILD_CFLAGS in configure.ac
@@ -88,6 +90,13 @@
$(CFLAGS) $(INTERNAL_CFLAGS) $(COVERAGE_FLAGS) $(WARN_CFLAGS) @DEFS@
# The C++ version.
+-ALL_CXXFLAGS = $(T_CFLAGS) $(CXXFLAGS) $(INTERNAL_CFLAGS) \
+- $(COVERAGE_FLAGS) $(WARN_CXXFLAGS) @DEFS@
++ALL_CXXFLAGS = $(ESP_NOPIE_CFLAGS) $(T_CFLAGS) $(CXXFLAGS) \
++ $(INTERNAL_CFLAGS) $(COVERAGE_FLAGS) $(WARN_CXXFLAGS) @DEFS@
+
+ # Likewise. Put INCLUDES at the beginning: this way, if some autoconf macro
+ # puts -I options in CPPFLAGS, our include files in the srcdir will always
@@ -1856,9 +1873,10 @@
echo LIBGCC_SYNC = '$(LIBGCC_SYNC)' >> tmp-libgcc.mvars
echo LIBGCC_SYNC_CFLAGS = '$(LIBGCC_SYNC_CFLAGS)' >> tmp-libgcc.mvars
@@ -96,7 +105,7 @@
+ echo CRTSTUFF_T_CFLAGS = '$(CRTSTUFF_T_CFLAGS) $(ESP_NOPIE_CFLAGS)' >> tmp-libgcc.mvars
echo CRTSTUFF_T_CFLAGS_S = '$(CRTSTUFF_T_CFLAGS_S)' >> tmp-libgcc.mvars
echo TARGET_SYSTEM_ROOT = '$(TARGET_SYSTEM_ROOT)' >> tmp-libgcc.mvars
-+ echo enable_crtbeginTS = '$(enable_crtbeginTS)' >> tmp-libgcc.mvars
++ echo enable_crtbeginP = '$(enable_crtbeginP)' >> tmp-libgcc.mvars
mv tmp-libgcc.mvars libgcc.mvars
@@ -109,12 +118,12 @@
-o $(T)crtbeginT$(objext)
+# This is a version of crtbegin for -static -fPIE links if esp is enable.
-+ifeq ($(enable_crtbeginTS),yes)
-+$(T)crtbeginTS.o: crtstuff.c $(GCC_PASSES) $(TCONFIG_H) auto-host.h \
++ifeq ($(enable_crtbeginP),yes)
++$(T)crtbeginP.o: crtstuff.c $(GCC_PASSES) $(TCONFIG_H) auto-host.h \
+ gbl-ctors.h stmp-int-hdrs tsystem.h coretypes.h $(TM_H)
+ $(GCC_FOR_TARGET) $(CRTSTUFF_CFLAGS) $(CRTSTUFF_T_CFLAGS_S) \
+ -c $(srcdir)/crtstuff.c -DCRT_BEGIN -DCRTSTUFFT_O -DCRTSTUFFS_O \
-+ -o $(T)crtbeginTS$(objext)
++ -o $(T)crtbeginP$(objext)
+endif
+
# Compile the start modules crt0.o and mcrt0.o that are linked with
@@ -126,10 +135,10 @@
gen-hide-list = echo > \$@
endif
-+# We add crtbeginTS.o to the EXTRA_PARTS list if enable_crtbeginTS = yes
-+enable_libgcc_crtbeginTS = $(enable_crtbeginTS)
-+ifeq ($(enable_libgcc_crtbeginTS),yes)
-+EXTRA_PARTS += crtbeginTS.o
++# We add crtbeginP.o to the EXTRA_PARTS list if enable_crtbeginP = yes
++enable_libgcc_crtbeginP = $(enable_crtbeginP)
++ifeq ($(enable_libgcc_crtbeginP),yes)
++EXTRA_PARTS += crtbeginP.o
+endif
+
ifneq ($(EXTRA_PARTS),)
@@ -141,8 +150,8 @@
-c $(gcc_srcdir)/crtstuff.c -DCRT_BEGIN -DCRTSTUFFT_O
+
+# This is a version of crtbegin for -static -fPIE links.
-+ifeq ($(enable_libgcc_crtbeginTS),yes)
-+crtbeginTS.o: $(gcc_srcdir)/crtstuff.c
++ifeq ($(enable_libgcc_crtbeginP),yes)
++crtbeginP.o: $(gcc_srcdir)/crtstuff.c
+ $(crt_compile) $(CRTSTUFF_T_CFLAGS_S) \
+ -c $(gcc_srcdir)/crtstuff.c -DCRT_BEGIN -DCRTSTUFFT_O -DCRTSTUFFS_O
+endif
diff --git a/4.6.2/pie/30_all_gcc44_esp.h.patch b/4.6.2/pie/30_all_gcc45_esp.h.patch
index df3c2bc..c51e8b4 100644
--- a/4.6.2/pie/30_all_gcc44_esp.h.patch
+++ b/4.6.2/pie/30_all_gcc45_esp.h.patch
@@ -1,13 +1,13 @@
-2010-05-27 Magnus Granberg <zorry@gentoo.org>
+2011-12-05 Magnus Granberg <zorry@gentoo.org>
* gcc/esp.h New file to support --enable-esp
- Version 20100527.1
+ Version 20111205.1
--- gcc/esp.h 2010-04-09 16:14:00.000000000 +0200
+++ gcc/esp.h 2010-04-29 21:30:47.000000000 +0200
@@ -0,0 +1,145 @@
+/* License terms see GNU GENERAL PUBLIC LICENSE Version 3.
-+ * Version 20100527.1
++ * Version 20111205.1
+ * Magnus Granberg (Zorry) <zorry@gentoo.org> */
+#ifndef GCC_ESP_H
+#define GCC_ESP_H
@@ -21,7 +21,7 @@
+ ESP_CC1_SPEC is added to CC1_SPEC.
+ ESP_CC1_STRICT_OVERFLOW_SPEC is added so we don't disable the strict-overflow check.
+ ESP_LINK_PIE_CHECK_SPEC check for -pie, -p, -pg, -profile and -static.
-+ ENABLE_CRTBEGINTS add support for crtbeginTS.o, build -static with -fPIE or -fpie.
++ ENABLE_CRTBEGINP add support for crtbeginP.o, build -static with -fPIE or -fpie.
+*/
+#ifdef ENABLE_ESP
+
@@ -70,8 +70,8 @@
+
+ /* This will add -fPIE if we don't have -pie -fpic -fPIC -fpie -fPIE -fno-pic -fno-PIC -fno-pie -fno-PIE -shared -static
+ -nostdlib -nostartfiles. */
-+ /* With ENABLE_CRTBEGINTS we don't need to check for -static */
-+ #ifdef ENABLE_CRTBEGINTS
++ /* With ENABLE_CRTBEGINP we don't need to check for -static */
++ #ifdef ENABLE_CRTBEGINP
+ #define ESP_OPTIONS_PIE_SPEC \
+ "%{!pie: %{!fpic:%{!fPIC:%{!fpie:%{!fPIE: %{!fno-pic:%{!fno-PIC:%{!fno-pie:%{!fno-PIE: \
+ %{!shared: %{!nostdlib: %{!nostartfiles:-fPIE}} } }}}} }}}} }"
@@ -83,9 +83,9 @@
+
+ /* This will add -pie if we don't have -pie -A -fno-pic -fno-PIC -fno-pie -fno-PIE -shared -static -r -nostdlib
+ -nostartfiles */
-+ /* With ENABLE_CRTBEGINTS we don't need to check for -static
++ /* With ENABLE_CRTBEGINP we don't need to check for -static
+ and we add -pie only to get the start and endfiles. -pie will not go to the linker. */
-+ #ifdef ENABLE_CRTBEGINTS
++ #ifdef ENABLE_CRTBEGINP
+ #define ESP_LINK_PIE_SPEC \
+ "%{!pie:%{!A:%{!fno-pie:%{!fno-PIE:%{!fno-pic:%{!fno-PIC:%{!shared:%{!r: \
+ %{!nostdlib:%{!nostartfiles:-pie}}}}}}}}}}"
@@ -97,8 +97,8 @@
+
+ /* This will check if -pie is set when (-static) -pg -p -profile. If set it will make gcc print out
+ "-pie and (static)|pg|p|profile are incompatible when linking" */
-+ /* With ENABLE_CRTBEGINTS we don't need to check for -static */
-+ #ifdef ENABLE_CRTBEGINTS
++ /* With ENABLE_CRTBEGINP we don't need to check for -static */
++ #ifdef ENABLE_CRTBEGINP
+ #define ESP_LINK_PIE_CHECK_SPEC \
+ "%{pie:%{pg|p|profile:%e-pie and -pg|p|profile are incompatible when linking}}"
+ #else
@@ -107,7 +107,7 @@
+ #endif
+
+ /* We don't pass -pie to the linker when -static. */
-+ #ifdef ENABLE_CRTBEGINTS
++ #ifdef ENABLE_CRTBEGINP
+ #define LINK_PIE_SPEC "%{!static:%{pie:-pie}} %(esp_link)"
+ #else
+ #define LINK_PIE_SPEC "%{pie:-pie} %(esp_link)"
diff --git a/4.6.2/pie/35_all_gcc46_config_crtbegints.patch b/4.6.2/pie/35_all_gcc46_config_crtbeginp.patch
index 7392252..0e716b0 100644
--- a/4.6.2/pie/35_all_gcc46_config_crtbegints.patch
+++ b/4.6.2/pie/35_all_gcc46_config_crtbeginp.patch
@@ -1,7 +1,7 @@
2011-03-05 Magnus Granberg <zorry@gentoo.org>
- * gcc/config/gnu-user.h If ENABLE_CRTBEGINTS, -static and -pie use crtbegineTS.o.
- * gcc/config/rs6000/sysv4.h If ENABLE_CRTBEGINTS, -static and -pie use crtbegineTS.o.
+ * gcc/config/gnu-user.h If ENABLE_CRTBEGINP, -static and -pie use crtbegineP.o.
+ * gcc/config/rs6000/sysv4.h If ENABLE_CRTBEGINP, -static and -pie use crtbegineP.o.
--- gcc/config/gnu-user.h 2009-04-10 01:23:07.000000000 +0200
+++ gcc/config/gnu-user.h 2009-09-08 04:08:06.000000000 +0200
@@ -10,11 +10,11 @@
object constructed before entering `main'. */
-#if defined HAVE_LD_PIE
-+#if defined (HAVE_LD_PIE) && defined (ENABLE_CRTBEGINTS)
++#if defined (HAVE_LD_PIE) && defined (ENABLE_CRTBEGINP)
+#define GNU_USER_TARGET_STARTFILE_SPEC \
+ "%{!shared: %{pg|p|profile:gcrt1.o%s;pie:Scrt1.o%s;:crt1.o%s}} crti.o%s \
-+ %{static:%{pie:crtbeginTS.o%s;:crtbeginT.o%s}} %{!static:%{shared|pie:crtbeginS.o%s;:crtbegin.o%s}}"
-+#elif defined (HAVE_LD_PIE) && ! defined (ENABLE_CRTBEGINTS)
++ %{static:%{pie:crtbeginP.o%s;:crtbeginT.o%s}} %{!static:%{shared|pie:crtbeginS.o%s;:crtbegin.o%s}}"
++#elif defined (HAVE_LD_PIE) && ! defined (ENABLE_CRTBEGINP)
#define GNU_USER_TARGET_STARTFILE_SPEC \
"%{!shared: %{pg|p|profile:gcrt1.o%s;pie:Scrt1.o%s;:crt1.o%s}} \
crti.o%s %{static:crtbeginT.o%s;shared|pie:crtbeginS.o%s;:crtbegin.o%s}"
@@ -25,12 +25,12 @@
%{!shared: %{profile:-lc_p} %{!profile:-lc}}}"
-#ifdef HAVE_LD_PIE
-+#if defined (HAVE_LD_PIE) && defined (ENABLE_CRTBEGINTS)
++#if defined (HAVE_LD_PIE) && defined (ENABLE_CRTBEGINP)
+#define STARTFILE_LINUX_SPEC "\
+%{!shared: %{pg|p|profile:gcrt1.o%s;pie:Scrt1.o%s;:crt1.o%s}} \
+%{mnewlib:ecrti.o%s;:crti.o%s} \
-+%{static:%{pie:crtbeginTS.o%s;:crtbeginT.o%s}} %{!static:%{shared|pie:crtbeginS.o%s;:crtbegin.o%s}}"
-+#elif defined (HAVE_LD_PIE) && ! defined (ENABLE_CRTBEGINTS)
++%{static:%{pie:crtbeginP.o%s;:crtbeginT.o%s}} %{!static:%{shared|pie:crtbeginS.o%s;:crtbegin.o%s}}"
++#elif defined (HAVE_LD_PIE) && ! defined (ENABLE_CRTBEGINP)
#define STARTFILE_LINUX_SPEC "\
%{!shared: %{pg|p|profile:gcrt1.o%s;pie:Scrt1.o%s;:crt1.o%s}} \
%{mnewlib:ecrti.o%s;:crti.o%s} \
diff --git a/4.6.2/pie/README.Changelog b/4.6.2/pie/README.Changelog
index e205273..abf59f9 100644
--- a/4.6.2/pie/README.Changelog
+++ b/4.6.2/pie/README.Changelog
@@ -1,4 +1,20 @@
-0.4.8 Magnus granberg <zorry@gentoo.org>
+0.5.0 Magnus Granberg <zorry@gentoo.org>
+
+ #393321
+ * gcc/Makefile.in Rename crtbeginTS.o to crtbeginP.o
+ * gcc/config/gnu-user.h Rename crtbeginTS.o to crtbeginP.o
+ * gcc/config/rs6000/sysv4.h Rename crtbeginTS.o to crtbeginP.o
+ * gcc/esp.h Rename crtbeginTS.o to crtbeginP.o
+ * gcc/configure Rename crtbeginTS.o to crtbeginP.o
+ * gcc/config.in Rename crtbeginTS.o to crtbeginP.o
+ * libgcc/Makefile.in Rename crtbeginTS.o to crtbeginP.o
+
+0.4.9 Magnus Granberg <zorry@gentoo.org>
+
+ #380823
+ * gcc/Makefile.in added ESP_NOPIE_CFLAGS to ALL_CXXFLAGS
+
+0.4.8 Magnus Granberg <zorry@gentoo.org>
* gcc/objc/lang-specs.h Bumped for gcc 4.6.0 release
* gcc/objcp/lang-specs.h Bumped for gcc 4.6.0 release
@@ -6,13 +22,13 @@
0.4.7 Magnus Granberg <zorry@gentoo.org>
- * gcc/gcc.c Add %(esp_options) and %(esp_cpp_options)
- * gcc/esp.h Use the esp.h patch from gcc-4.4 patchset
- * gcc/config/rs6000/linux64.h Bumed for >2011-02-26 snapshot
- * gcc/objc/lang-specs.h Add %(esp_options)
- * gcc/objcp/lang-specs.h Add %(esp_options)
- * gcc/cp/lang-specs.h Add %(esp_options)
- * gcc/config/gnu-user.h Add crtbeginTS.o support
+ * gcc/gcc.c Add %(esp_options) and %(esp_cpp_options)
+ * gcc/esp.h Use the esp.h patch from gcc-4.4 patchset
+ * gcc/config/rs6000/linux64.h Bumed for >2011-02-26 snapshot
+ * gcc/objc/lang-specs.h Add %(esp_options)
+ * gcc/objcp/lang-specs.h Add %(esp_options)
+ * gcc/cp/lang-specs.h Add %(esp_options)
+ * gcc/config/gnu-user.h Add crtbeginTS.o support
0.4.6 Magnus Granberg <zorry@gentoo.org>
diff --git a/4.6.2/pie/README.history b/4.6.2/pie/README.history
index 8535288..49980dc 100644
--- a/4.6.2/pie/README.history
+++ b/4.6.2/pie/README.history
@@ -1,3 +1,14 @@
+0.5.0 07-12-2011
+ + 35_all_gcc46_config_crtbeginp.patch
+ - 35_all_gcc46_config_crtbegints.patch
+ U 10_all_gcc45_configure.patch
+ U 12_all_gcc46_Makefile.in.patch
+ + 11_all_gcc45_config.in.patch
+ - 11_all_gcc44_config.in.patch
+ + 30_all_gcc45_esp.h.patch
+ - 30_all_gcc44_esp.h.patch
+0.4.9 09-11-2011
+ U 12_all_gcc46_Makefile.in.patch
0.4.8 26-03-2011
U 22_all_gcc46-default-ssp.patch
0.4.7 05-03-2011
@@ -6,7 +17,7 @@
- 30_all_gcc46_esp.h.patch
+ 30_all_gcc44_esp.h.patch
U 33_all_gcc46_config_rs6000_linux64.h.patch
- U 35_all_gcc44_config_crtbegints.patch
+ U 35_all_gcc46_config_crtbegints.patch
0.4.6 07-01-2011
+ 12_all_gcc46_Makefile.in.patch
- 12_all_gcc44_Makefile.in.patch