summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnustep-apps/etoile/etoile-0.2.ebuild')
-rw-r--r--gnustep-apps/etoile/etoile-0.2.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/gnustep-apps/etoile/etoile-0.2.ebuild b/gnustep-apps/etoile/etoile-0.2.ebuild
new file mode 100644
index 0000000..f9a14b8
--- /dev/null
+++ b/gnustep-apps/etoile/etoile-0.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="prefix"
+
+inherit gnustep-2
+
+S="${WORKDIR}/Etoile-${PV}/Services/Private/System"
+
+DESCRIPTION="Meta-package for the Etoile desktop environment"
+HOMEPAGE="http://www.etoile-project.org"
+SRC_URI="http://download.gna.org/etoile/etoile-${PV}.tar.gz"
+
+LICENSE="as-is"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+
+RDEPEND=">=gnustep-apps/addresses-0.4.7
+ ~gnustep-apps/azalea-${PV}
+ ~gnustep-apps/azbackground-${PV}
+ ~gnustep-apps/azdock-${PV}
+ ~gnustep-apps/azswitch-${PV}
+ ~gnustep-apps/calc-${PV}
+ ~gnustep-apps/dictionaryreader-${PV}
+ ~gnustep-apps/etoile-corner-${PV}
+ ~gnustep-apps/etoile-idle-${PV}
+ ~gnustep-apps/etoile-menuserver-${PV}
+ ~gnustep-apps/etoile-system-${PV}
+ ~gnustep-apps/fontmanager-${PV}
+ ~gnustep-apps/grr-${PV}
+ ~gnustep-apps/outerspace-${PV}
+ ~gnustep-apps/sketch-${PV}
+ ~gnustep-apps/stepchat-${PV}
+ ~gnustep-apps/typewriter-${PV}
+ ~gnustep-apps/vindaloo-${PV}
+ ~gnustep-libs/camaelon-${PV}
+ ~gnustep-libs/etoile-behavior-${PV}
+ ~gnustep-libs/etoile-wildmenus-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Fix path
+ egnustep_env
+ sed -i "s#/usr/local/bin/etoile#${GNUSTEP_SYSTEM_TOOLS}/etoile_system#" \
+ etoile.desktop || die "Fixing desktop file failed"
+}
+
+src_compile() {
+ einfo "Nothing to compile"
+}
+
+src_install() {
+ egnustep_env
+
+ # Install SystemTaskList
+ dodir ${GNUSTEP_SYSTEM_LIBRARY#${EPREFIX}}/Etoile
+ insinto ${GNUSTEP_SYSTEM_LIBRARY#${EPREFIX}}/Etoile
+ doins SystemTaskList.plist
+
+ # Install desktop entry file
+ insinto /usr/share/xsessions
+ doins etoile.desktop
+}
+
+pkg_postinst() {
+ elog "Thanks for trying Etoile ebuilds from the GNUstep overlay"
+ elog "This is still a work in progress. For now,"
+ elog "to enable all Etoile features, you will need to run (as user):"
+ elog "# defaults write NSGlobalDomain GSAppKitUserBundles '("
+ elog "\"/usr/GNUstep/System/Library/Bundles/Camaelon.themeEngine\","
+ elog "\"/usr/GNUstep/System/Library/Bundles/EtoileMenus.bundle",
+ elog "\"/usr/GNUstep/System/Library/Bundles/EtoileBehavior.bundle\")'"
+ elog "This will probably be changed in the near future"
+}