aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPriit Laes <plaes@plaes.org>2010-07-21 19:08:13 +0300
committerPriit Laes <plaes@plaes.org>2010-07-21 19:08:13 +0300
commit6db537d37cb7581164807ff77ab127eb7612bab6 (patch)
tree0bb59b86e5422c44c6b7d6e479080c14a856ffde
parentImplement account confirmation (diff)
downloadgsoc2010-grumpy-6db537d37cb7581164807ff77ab127eb7612bab6.tar.gz
gsoc2010-grumpy-6db537d37cb7581164807ff77ab127eb7612bab6.tar.bz2
gsoc2010-grumpy-6db537d37cb7581164807ff77ab127eb7612bab6.zip
Added testsuite skeleton
-rw-r--r--grumpy/testsuite/__init__.py25
-rw-r--r--setup.py1
2 files changed, 26 insertions, 0 deletions
diff --git a/grumpy/testsuite/__init__.py b/grumpy/testsuite/__init__.py
new file mode 100644
index 0000000..39695f2
--- /dev/null
+++ b/grumpy/testsuite/__init__.py
@@ -0,0 +1,25 @@
+# -*- coding: utf-8 -*-
+"""
+ grumpy.testsuite
+ ~~~~~~~~~~~~~~~~
+
+ Unittests for Grumpy project.
+
+ :copyright: (c) by 2010 Priit Laes.
+ :license: BSD, see LICENSE for details.
+"""
+import unittest
+
+class GrumpyTestCase(unittest.TestCase):
+
+ def setUp(self):
+ # TODO: init application and database
+ pass
+
+ def tearDown(self):
+ # TODO: stop application and drop database
+ pass
+
+def suite():
+ suite = unittest.TestSuite()
+ return suite
diff --git a/setup.py b/setup.py
index 7aa9cb3..c43a9a8 100644
--- a/setup.py
+++ b/setup.py
@@ -56,6 +56,7 @@ setup(
long_description=__doc__,
packages=['grumpy'],
scripts=[join('utils', 'grumpy_sync.py')],
+ test_suite='grumpy.testsuite.suite',
zip_safe=False,
platforms='any',
install_requires=[