summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-12-07 15:35:54 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-12-07 17:36:31 +0100
commit21cbb048d1f94f5ca3e26acfb3ac250231648b55 (patch)
tree2d1015ad287906607c39ad1855715dee18ffc0b1 /kde-misc
parentnet-misc/mDNSResponder: Remove obsolete package, no more revdeps (diff)
downloadkde-sunset-21cbb048d1f94f5ca3e26acfb3ac250231648b55.tar.gz
kde-sunset-21cbb048d1f94f5ca3e26acfb3ac250231648b55.tar.bz2
kde-sunset-21cbb048d1f94f5ca3e26acfb3ac250231648b55.zip
kde-misc/kdirstat: 2.7.8 version bump
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/kdirstat/Manifest1
-rw-r--r--kde-misc/kdirstat/kdirstat-2.7.8.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/kde-misc/kdirstat/Manifest b/kde-misc/kdirstat/Manifest
index dbeb1811..85866557 100644
--- a/kde-misc/kdirstat/Manifest
+++ b/kde-misc/kdirstat/Manifest
@@ -1 +1,2 @@
DIST k4dirstat-2.7.5.tar.bz2 225485 BLAKE2B c47b3341ea44ddff1d60ab06ea03495f191566fd12035a74dae6d3a168f7c4b16b21dc14e580f1b806217a548e1f891f571504fdb6f0fcdb87d38a775bcde6d3 SHA512 57853c00c26cbef13523455c854e38da7eddfb4382c6143a25a2c43a319c4c03037cba44340097c0612a329f2308f0f1e54ffe8cf1329d8d05755231a50da895
+DIST k4dirstat-2.7.8.tar.gz 255605 BLAKE2B 5a2f4192a455d05a0e280bec4aebc155128fb5759465e28d5f5b6d120c9375ed1d8c4bf1cf7ba656fa7d14612b4930c9d00bebf2787e8f2fef9dc697126fde82 SHA512 5e2dd337fc8aa5eabaafd582e54825aec9a43b94368d975476eb28d8215370b36201d8e96df808af789b08624793ccd328c41a2af9fbbffe192395ec3af8ea13
diff --git a/kde-misc/kdirstat/kdirstat-2.7.8.ebuild b/kde-misc/kdirstat/kdirstat-2.7.8.ebuild
new file mode 100644
index 00000000..d098c659
--- /dev/null
+++ b/kde-misc/kdirstat/kdirstat-2.7.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=k4dirstat
+inherit xdg cmake
+
+DESCRIPTION="Graphically displays disk space used up by a directory tree"
+HOMEPAGE="https://github.com/jeromerobert/k4dirstat"
+SRC_URI="https://github.com/jeromerobert/${MY_PN}/archive/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${MY_PN}-${PV}"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+DEPEND="
+ dev-qt/qt3support:4
+ dev-qt/qtcore:4[qt3support]
+ dev-qt/qtgui:4[qt3support]
+ kde-apps/libkonq:4
+ kde-frameworks/kdelibs[qt3support]
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=( -DK4DIRSTAT_GIT_VERSION=OFF )
+ cmake_src_configure
+}