summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <gentoo@mgorny.alt.pl>2010-04-10 15:27:28 +0200
committerMichał Górny <gentoo@mgorny.alt.pl>2010-04-10 15:27:28 +0200
commit8f9b148bdeb4dac7b43b2ff6a4adea10c41773e4 (patch)
treeaaf256e0fbf7626c4510afab237f07d2cc9ad429 /sci-electronics
parentAdding myself to the commiters list. (diff)
downloadkde-sunset-8f9b148bdeb4dac7b43b2ff6a4adea10c41773e4.tar.gz
kde-sunset-8f9b148bdeb4dac7b43b2ff6a4adea10c41773e4.tar.bz2
kde-sunset-8f9b148bdeb4dac7b43b2ff6a4adea10c41773e4.zip
[sci-electronics/qucs] Reimport of the Qt3 version of qucs.
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/qucs/ChangeLog9
-rw-r--r--sci-electronics/qucs/Manifest4
-rw-r--r--sci-electronics/qucs/metadata.xml15
-rw-r--r--sci-electronics/qucs/qucs-0.0.15.ebuild31
4 files changed, 59 insertions, 0 deletions
diff --git a/sci-electronics/qucs/ChangeLog b/sci-electronics/qucs/ChangeLog
new file mode 100644
index 00000000..578425e6
--- /dev/null
+++ b/sci-electronics/qucs/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sci-electronics/qucs
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header$
+
+*qucs-0.0.15 (10 Apr 2010)
+
+ 10 Apr 2010; Michał Górny <gentoo@mgorny.alt.pl> +qucs-0.0.15.ebuild:
+ Reimport of the Qt3 version of qucs.
+
diff --git a/sci-electronics/qucs/Manifest b/sci-electronics/qucs/Manifest
new file mode 100644
index 00000000..5fa9b3c8
--- /dev/null
+++ b/sci-electronics/qucs/Manifest
@@ -0,0 +1,4 @@
+DIST qucs-0.0.15.tar.gz 6381836 RMD160 ced0243add1600bf6645963248051c7aef7903de SHA1 fa0d19cbb49991d03e25726251bd153f3005732a SHA256 57f7525051151cc3f9e3044aed766f1f34c02479bfae0c28380223c9a215fa3d
+EBUILD qucs-0.0.15.ebuild 677 RMD160 4ca485e6ddc1e6b0cd30f77c28fd1cd074de784f SHA1 eda993683505b3727b65d4ff611a6c98ceae4e14 SHA256 afc1912b75fb4b623ec29244a3960de5ea8006bc84afc7aea668df6b55348f3a
+MISC ChangeLog 261 RMD160 a8de3399545ffe4abab455e3c7ea0e784b52f5a5 SHA1 9ee76df95e20e5afa36f9b7c7b645ed9dea1e966 SHA256 fc6ee752df982246533b3501ac3a2d9ecef45d415d1dc12c6fa7389a81449893
+MISC metadata.xml 603 RMD160 40298c5d0db19d14569c8ee194393bc40836980d SHA1 cc1d7ebf0cb25e3fe8a174ecec18cf20ef51b176 SHA256 049b604517e7507a714336c73f4014be5413c296e23467e1763dd26b0880ef09
diff --git a/sci-electronics/qucs/metadata.xml b/sci-electronics/qucs/metadata.xml
new file mode 100644
index 00000000..0edd7b08
--- /dev/null
+++ b/sci-electronics/qucs/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-electronics</herd>
+ <maintainer>
+ <email>cryos@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Qucs is a Qt based integrated circuit simulator. It allows you to set up a
+ circuit with a graphical user interface and simulate the large-signal,
+ small-signal and noise behaviour of the circuit. The simulation results can
+ then be viewed graphically. Qucsator is made available as a command line
+ simulation backend.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-electronics/qucs/qucs-0.0.15.ebuild b/sci-electronics/qucs/qucs-0.0.15.ebuild
new file mode 100644
index 00000000..095c2621
--- /dev/null
+++ b/sci-electronics/qucs/qucs-0.0.15.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Quite Universal Circuit Simulator is a Qt based circuit simulator"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://qucs.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+DEPEND="x11-libs/qt:3"
+RDEPEND="x11-libs/qt:3
+ >=sci-electronics/freehdl-0.0.7"
+
+src_configure() {
+ econf --with-x $(use_enable debug)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ doicon qucs/bitmaps/big.qucs.xpm || die
+ make_desktop_entry qucs Qucs qucs "Qt;Science;Electronics"
+}