summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-08-14 01:22:18 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-08-14 11:06:30 +0200
commitc512c4528202ea8de782ebad959c804f6fd2ae94 (patch)
tree41e1bf531f4397ec398be6a1c44b1864d5a87a6d /sci-electronics
parentdev-qt/qt-meta: Drop stale CVS header (diff)
downloadkde-sunset-c512c4528202ea8de782ebad959c804f6fd2ae94.tar.gz
kde-sunset-c512c4528202ea8de782ebad959c804f6fd2ae94.tar.bz2
kde-sunset-c512c4528202ea8de782ebad959c804f6fd2ae94.zip
sci-electronics/qucs: Import 0.0.18 from Gentoo repo before last-rites
Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/qucs/Manifest3
-rw-r--r--sci-electronics/qucs/metadata.xml19
-rw-r--r--sci-electronics/qucs/qucs-0.0.18.ebuild68
3 files changed, 78 insertions, 12 deletions
diff --git a/sci-electronics/qucs/Manifest b/sci-electronics/qucs/Manifest
index 7841e50c..f3e83c08 100644
--- a/sci-electronics/qucs/Manifest
+++ b/sci-electronics/qucs/Manifest
@@ -1 +1,2 @@
-DIST qucs-0.0.15.tar.gz 6381836 SHA256 57f7525051151cc3f9e3044aed766f1f34c02479bfae0c28380223c9a215fa3d
+DIST qucs-0.0.15.tar.gz 6381836 BLAKE2B c5d9ed3ba0c51355b065c5e7e1173eda3adbaef391e0ff569fe8e1893d67e77ccdff466e4eb9293f527685da849396b7aae8aba72f85243e609d28fe04ce2cd3 SHA512 7c73d4d4f423cc4d0e4a2e6f61bf6ac91c0e63e1b6834ebab361c31e5397d58d12f174d5994e308e592591f1ea771ad28376a123daedde60695110d46b9e60c2
+DIST qucs-0.0.18.tar.gz 45270816 BLAKE2B 84c70f23fc91decf4b237cab507c2a5de482126c27978e7c331264fc584323cf16c37509212e98f84aa0fd6c847a0aeb3d568bdb23c5551a357c9a794c96d614 SHA512 b6836837fde44fe04e6a0533905c7bbfdbb6f64412fbc2516cab281de2ec51738cf62bb245763a0be6711e02392f8d73e87b86bff6eb432fe3bbf47636c98313
diff --git a/sci-electronics/qucs/metadata.xml b/sci-electronics/qucs/metadata.xml
index 77a00371..9ad02b65 100644
--- a/sci-electronics/qucs/metadata.xml
+++ b/sci-electronics/qucs/metadata.xml
@@ -1,15 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
- <maintainer>
- <email>cryos@gentoo.org</email>
- </maintainer>
- <longdescription>
- Qucs is a Qt based integrated circuit simulator. It allows you to set up a
- circuit with a graphical user interface and simulate the large-signal,
- small-signal and noise behaviour of the circuit. The simulation results can
- then be viewed graphically. Qucsator is made available as a command line
- simulation backend.
- </longdescription>
+ <!-- maintainer-needed -->
+ <longdescription>
+ Qucs is a Qt based integrated circuit simulator. It allows you to set up a
+ circuit with a graphical user interface and simulate the large-signal,
+ small-signal and noise behaviour of the circuit. The simulation results can
+ then be viewed graphically. Qucsator is made available as a command line
+ simulation backend.
+ </longdescription>
</pkgmetadata>
diff --git a/sci-electronics/qucs/qucs-0.0.18.ebuild b/sci-electronics/qucs/qucs-0.0.18.ebuild
new file mode 100644
index 00000000..dfb70bad
--- /dev/null
+++ b/sci-electronics/qucs/qucs-0.0.18.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Quite Universal Circuit Simulator in Qt4"
+HOMEPAGE="http://qucs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="dev-qt/qtcore:4[qt3support]
+ dev-qt/qtgui:4[qt3support]
+ dev-qt/qtscript:4
+ dev-qt/qtsvg:4
+ dev-qt/qt3support:4
+ x11-libs/libX11:0="
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-gcc6.patch )
+
+src_prepare() {
+ default
+
+ # oh my, they strip -g out of C*FLAGS and force -s into LDFLAGS
+ # note: edit .ac first, then generated files, so that the latter
+ # have newer timestamp and not trigger regen
+ sed -i \
+ -e 's/C.*FLAGS.*sed.*-g.*$/:/' \
+ -e 's/C.*FLAGS.*-O0.*$/:/' \
+ -e 's/LDFLAGS.*-s.*$/:/' \
+ configure.ac asco/configure.ac qucs-core/configure.ac \
+ configure asco/configure qucs-core/configure \
+ || die "C*FLAGS and LDFLAGS sanitization sed failed"
+}
+
+src_configure() {
+ local myconf=(
+ # enables asserts and debug codepaths
+ $(use_enable debug)
+
+ # avoid automagic dep
+ # TODO: add support for it
+ --disable-mpi
+ )
+
+ # automagic default on clang++
+ tc-export CXX
+
+ # the package doesn't use pkg-config on Linux, only on Darwin
+ # very smart of upstream...
+ append-ldflags $( $(tc-getPKG_CONFIG) --libs-only-L \
+ QtCore QtGui QtScript QtSvg QtXml Qt3Support )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ if ! has_version 'sci-electronics/freehdl'; then
+ elog "If you would like to be able to run digital simulations, please install:"
+ elog " sci-electronics/freehdl"
+ fi
+}