aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Eloe <powerofazure@gmail.com>2010-08-09 15:11:27 -0500
committerNathan Eloe <powerofazure@gmail.com>2010-08-13 11:45:56 -0500
commit7cc230e6b5f06b876dbccbb80b48603758180192 (patch)
tree7d3bd66ab61fdc955d6bb55d70e65f7134ab5a8f /configure.ac
parentBuild system for coding style (diff)
downloadlibbash-7cc230e6b5f06b876dbccbb80b48603758180192.tar.gz
libbash-7cc230e6b5f06b876dbccbb80b48603758180192.tar.bz2
libbash-7cc230e6b5f06b876dbccbb80b48603758180192.zip
Doxygen configuration and build system integration
Creates the configuration file for Doxygen Adds support to the build system for Doxygen documentation. Default output type is html and latex. After configuring, run make doxygen-doc to generate documentation. Documentation will reside in the docs directory. Please see ./configure --help for related options
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 728550f..b5dafb1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -42,4 +42,13 @@ if test "$PDFLATEX" = "no"; then
fi
AC_CHECK_LIB([antlr3c],[antlr3AsciiFileStreamNew],[],[AC_MSG_ERROR(libasntlr3c not found. Have you installed the C antlr runtime?)])
AC_CONFIG_FILES([Makefile])
+DX_HTML_FEATURE(ON)
+DX_MAN_FEATURE(OFF)
+DX_CHM_FEATURE(OFF)
+DX_CHI_FEATURE(OFF)
+DX_RTF_FEATURE(OFF)
+DX_XML_FEATURE(OFF)
+DX_PDF_FEATURE(OFF)
+DX_PS_FEATURE(OFF)
+DX_INIT_DOXYGEN([$PACKAGE_NAME], [Doxyfile])
AC_OUTPUT