aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Eloe <powerofazure@gmail.com>2010-08-07 12:56:38 -0500
committerNathan Eloe <powerofazure@gmail.com>2010-08-22 12:47:29 -0500
commit8db685bf165b4de9840656e9c3dc13ff301cedab (patch)
tree027d199cfbe35d79385a710efeef86d1a096f3e6 /configure.ac
parentVirtual class for builtins (diff)
downloadlibbash-8db685bf165b4de9840656e9c3dc13ff301cedab.tar.gz
libbash-8db685bf165b4de9840656e9c3dc13ff301cedab.tar.bz2
libbash-8db685bf165b4de9840656e9c3dc13ff301cedab.zip
Echo builtin and associated unit tests
Implements echo as a builtin function. Uses google-test+ to test the functionality of the builtin. Adds the tests to make check in main build system. aclocal needs the flags -I m4 to pull all project m4s in.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 87b0b20..659cc38 100644
--- a/configure.ac
+++ b/configure.ac
@@ -18,7 +18,7 @@
AC_CONFIG_MACRO_DIR([m4])
AC_INIT([libbash], [0.1],[powerofazure@gmail.com])
-AM_INIT_AUTOMAKE([parallel-tests])
+AM_INIT_AUTOMAKE([parallel-tests subdir-objects])
AC_PREREQ([2.65])
AC_PROG_CXX
LT_INIT
@@ -28,6 +28,7 @@ AC_PATH_PROG([JAVA],[java],"no")
if test "$JAVA" = "no"; then
AC_MSG_ERROR([No java executable found])
fi
+GTEST_LIB_CHECK(,[:],[:])
AC_ARG_WITH(antlr, [],with_antlr=$withval,with_antlr=jc)
if test "$with_antlr" = "jc"; then
AC_PATH_PROG(JAVA_CONFIG, java-config, "no")