summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/ldm/Manifest1
-rw-r--r--x11-misc/ldm/ldm-9999.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/x11-misc/ldm/Manifest b/x11-misc/ldm/Manifest
new file mode 100644
index 0000000..f69ab50
--- /dev/null
+++ b/x11-misc/ldm/Manifest
@@ -0,0 +1 @@
+EBUILD ldm-9999.ebuild 648 RMD160 cb2729d566c540e5a66c64723462124c21444a5d SHA1 30909f3add5b61c0e4c448a69d50e6dd64ba9708 SHA256 b433445cbd920c67575218de36531ae9d4381a1a3a1d03958de8a5fbd1fbfd2f
diff --git a/x11-misc/ldm/ldm-9999.ebuild b/x11-misc/ldm/ldm-9999.ebuild
new file mode 100644
index 0000000..6e73045
--- /dev/null
+++ b/x11-misc/ldm/ldm-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit bzr
+EBZR_REPO_URI="http://bazaar.launchpad.net/~ltsp-upstream/ltsp/"
+EBZR_BRANCH="ldm-trunk"
+EBZR_BOOTSTRAP="autogen.sh"
+
+DESCRIPTION="LTSP Display Manager"
+HOMEPAGE="http://www.ltsp.org/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=dev-libs/glib-2.6
+ >=x11-libs/gtk+-2.2"
+RDEPEND="${DEPEND} net-misc/ltsp-client"
+src_unpack() {
+ bzr_src_unpack
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}