aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2021-03-10 09:19:43 -0600
committerJory Pratt <anarchy@gentoo.org>2021-03-10 09:19:43 -0600
commit412af79d1e12ddca4d625dde09e24f9e02726f04 (patch)
tree3a032bce2d07b530f6522b16bb0fc769c7209399 /media-libs
parentmedia-libs/mesa: unbreak intel users build (diff)
downloadmusl-412af79d1e12ddca4d625dde09e24f9e02726f04.tar.gz
musl-412af79d1e12ddca4d625dde09e24f9e02726f04.tar.bz2
musl-412af79d1e12ddca4d625dde09e24f9e02726f04.zip
media-libs/mesa: use upstream patch for git_sha1 generation missing
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Jory Pratt <anarchy@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mesa/files/mesa-20.3.4-intel-git_sha1.patch25
-rw-r--r--media-libs/mesa/files/mesa-20.3.4-missing-git_sha1.patch57
-rw-r--r--media-libs/mesa/mesa-20.3.4.ebuild2
3 files changed, 58 insertions, 26 deletions
diff --git a/media-libs/mesa/files/mesa-20.3.4-intel-git_sha1.patch b/media-libs/mesa/files/mesa-20.3.4-intel-git_sha1.patch
deleted file mode 100644
index 2919d57d..00000000
--- a/media-libs/mesa/files/mesa-20.3.4-intel-git_sha1.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 4ffaff669266dd5b633d2e44ca842c49f0a1d2fb Mon Sep 17 00:00:00 2001
-From: Jory Pratt <anarchy@gentoo.org>
-Date: Wed, 10 Mar 2021 08:48:37 -0600
-Subject: [PATCH] ensure git_sha1.h is generated for use
-
----
- src/intel/common/meson.build | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/intel/common/meson.build b/src/intel/common/meson.build
-index 66e0967..422d22a 100644
---- a/src/intel/common/meson.build
-+++ b/src/intel/common/meson.build
-@@ -42,7 +42,7 @@ files_libintel_common = files(
- )
-
- libintel_common = static_library(
-- ['intel_common', genX_xml_h],
-+ ['intel_common', genX_xml_h, sha1_h],
- files_libintel_common,
- include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_intel],
- c_args : [no_override_init_args],
---
-2.26.2
-
diff --git a/media-libs/mesa/files/mesa-20.3.4-missing-git_sha1.patch b/media-libs/mesa/files/mesa-20.3.4-missing-git_sha1.patch
new file mode 100644
index 00000000..c994a7ab
--- /dev/null
+++ b/media-libs/mesa/files/mesa-20.3.4-missing-git_sha1.patch
@@ -0,0 +1,57 @@
+From 434da21a7c81acbe03f0e1621e80904313c0b05c Mon Sep 17 00:00:00 2001
+From: Michael Forney <mforney@mforney.org>
+Date: Wed, 16 Dec 2020 00:48:25 -0800
+Subject: [PATCH] meson: add missing dependency on generated git_sha1.h
+
+Reviewed-by: Lionel Landwerlin <lionel.g.landwerlin@intel.com>
+Reviewed-by: Eric Anholt <eric@anholt.net>
+Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/8121>
+---
+ src/freedreno/common/meson.build | 1 +
+ src/gallium/frontends/lavapipe/meson.build | 2 +-
+ src/intel/common/meson.build | 4 ++--
+ 3 files changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/src/freedreno/common/meson.build b/src/freedreno/common/meson.build
+index 2da6c1eacf8..30ef23043a7 100644
+--- a/src/freedreno/common/meson.build
++++ b/src/freedreno/common/meson.build
+@@ -27,6 +27,7 @@ libfreedreno_common = static_library(
+ 'freedreno_uuid.c',
+ 'freedreno_uuid.h',
+ 'freedreno_guardband.h',
++ sha1_h,
+ ],
+ include_directories : [inc_freedreno, inc_include, inc_src, inc_gallium],
+ c_args : [no_override_init_args],
+diff --git a/src/gallium/frontends/lavapipe/meson.build b/src/gallium/frontends/lavapipe/meson.build
+index 972735fcff9..94c68d14d23 100644
+--- a/src/gallium/frontends/lavapipe/meson.build
++++ b/src/gallium/frontends/lavapipe/meson.build
+@@ -57,7 +57,7 @@ endif
+
+ liblavapipe_st = static_library(
+ 'lavapipe_st',
+- [liblvp_files, lvp_entrypoints, lvp_extensions_c ],
++ [liblvp_files, lvp_entrypoints, lvp_extensions_c, sha1_h],
+ link_with : [ libvulkan_wsi ],
+ c_args : [ lvp_flags ],
+ gnu_symbol_visibility : 'hidden',
+diff --git a/src/intel/common/meson.build b/src/intel/common/meson.build
+index 2586b4cf956..53c458f447d 100644
+--- a/src/intel/common/meson.build
++++ b/src/intel/common/meson.build
+@@ -42,8 +42,8 @@ files_libintel_common = files(
+ )
+
+ libintel_common = static_library(
+- ['intel_common', genX_xml_h],
+- files_libintel_common,
++ 'intel_common',
++ [files_libintel_common, genX_xml_h, sha1_h],
+ include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_intel],
+ c_args : [no_override_init_args],
+ gnu_symbol_visibility : 'hidden',
+--
+GitLab
+
diff --git a/media-libs/mesa/mesa-20.3.4.ebuild b/media-libs/mesa/mesa-20.3.4.ebuild
index acdeb099..001daa0e 100644
--- a/media-libs/mesa/mesa-20.3.4.ebuild
+++ b/media-libs/mesa/mesa-20.3.4.ebuild
@@ -243,7 +243,7 @@ x86? (
PATCHES=(
"${FILESDIR}"/${PN}-20.2.0-add-disable-tls-support.patch
- "${FILESDIR}"/${PN}-20.3.4-intel-git_sha1.patch
+ "${FILESDIR}"/${PN}-20.3.4-missing-git_sha1.patch
)
llvm_check_deps() {