aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcallmetango <callmetango@users.noreply.github.com>2020-07-04 11:04:27 +0200
committerAnthony G. Basile <blueness@gentoo.org>2020-07-09 13:06:45 -0400
commitb530fbc48d4888e9cde722b08d30166962ff7f1a (patch)
treedd4d82a6f47dd76b0282ce3b9ba8d8278c0a9052 /sys-apps
parentsys-apps/xdg-dbus-proxy: make it compile on musl (diff)
downloadmusl-b530fbc48d4888e9cde722b08d30166962ff7f1a.tar.gz
musl-b530fbc48d4888e9cde722b08d30166962ff7f1a.tar.bz2
musl-b530fbc48d4888e9cde722b08d30166962ff7f1a.zip
sys-apps/bubblewrap: version bump to 0.4.1
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/bubblewrap/Manifest2
-rw-r--r--sys-apps/bubblewrap/bubblewrap-0.4.1.ebuild (renamed from sys-apps/bubblewrap/bubblewrap-0.3.1-r1.ebuild)14
-rw-r--r--sys-apps/bubblewrap/files/bubblewrap-0.3.1-selinux-configure.patch224
3 files changed, 233 insertions, 7 deletions
diff --git a/sys-apps/bubblewrap/Manifest b/sys-apps/bubblewrap/Manifest
index 5ae1117b..7be60f2b 100644
--- a/sys-apps/bubblewrap/Manifest
+++ b/sys-apps/bubblewrap/Manifest
@@ -1 +1 @@
-DIST bubblewrap-0.3.1.tar.xz 209924 BLAKE2B bacc4080106cd9876bf0e1ad866a7397d7d232e61a720b52b5a6b9b0d860e625511ed15ac630aa71003fb9fa145ffa9d08ae2e6ba6d1411fd75e7d9568312717 SHA512 74e36caa56540a956158445f5f38c7ac5f7ff3c733ecaf85893de4607900e1fe4050db86a4435cbe18d722e90c5b39c466c555ea8ea8d4944da6207ef1011d67
+DIST bubblewrap-0.4.1.tar.xz 214496 BLAKE2B bdbff50cc4e28c91d83c814df7f2ee15702962d26a9316bd841b1e63bf5976c4549c88e20869e8cc236a8a0c9a065518f945c356fa7a058f8831f5b1e9d4eb0d SHA512 0ff46dc0fda2d0cffbb36cc52ff43951b30cbd835a42cc56806acbbbd827796bfadbb1cfafc84d6b47a72c031ca44abe1c377acc0cc25fe3b33e854f5f687d35
diff --git a/sys-apps/bubblewrap/bubblewrap-0.3.1-r1.ebuild b/sys-apps/bubblewrap/bubblewrap-0.4.1.ebuild
index a07e3f64..51a815f6 100644
--- a/sys-apps/bubblewrap/bubblewrap-0.3.1-r1.ebuild
+++ b/sys-apps/bubblewrap/bubblewrap-0.4.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,12 +6,12 @@ EAPI=7
inherit bash-completion-r1 linux-info
DESCRIPTION="Unprivileged sandboxing tool, namespaces-powered chroot-like solution"
-HOMEPAGE="https://github.com/projectatomic/bubblewrap"
-SRC_URI="https://github.com/projectatomic/${PN}/releases/download/v${PV}/${P}.tar.xz"
+HOMEPAGE="https://github.com/containers/bubblewrap/"
+SRC_URI="https://github.com/containers/${PN}/releases/download/v${PV}/${P}.tar.xz"
LICENSE="LGPL-2+"
SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 x86"
+KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 x86"
IUSE="selinux +suid"
RDEPEND="
@@ -28,8 +28,10 @@ DEPEND="${RDEPEND}
# tests require root priviledge
RESTRICT="test"
-
-PATCHES=( "${FILESDIR}"/${P}-missing-TEMP_FAILURE_RETRY.patch )
+PATCHES=(
+ "${FILESDIR}/${PN}-0.3.1-selinux-configure.patch" # bug 674312
+ "${FILESDIR}/${PN}-0.3.1-missing-TEMP_FAILURE_RETRY.patch"
+)
pkg_setup() {
if [[ ${MERGE_TYPE} != buildonly ]]; then
diff --git a/sys-apps/bubblewrap/files/bubblewrap-0.3.1-selinux-configure.patch b/sys-apps/bubblewrap/files/bubblewrap-0.3.1-selinux-configure.patch
new file mode 100644
index 00000000..b8fad6cc
--- /dev/null
+++ b/sys-apps/bubblewrap/files/bubblewrap-0.3.1-selinux-configure.patch
@@ -0,0 +1,224 @@
+Author: Jonas Jelten <jj@sft.mx>
+
+upstream decided to ship the generated ./configure file...
+here's the updated configure script with the missing PKG_PROG_PKG_CONFIG call
+
+===================================================================
+--- bubblewrap-0.3.1.orig/configure
++++ bubblewrap-0.3.1/configure
+@@ -5224,107 +5224,6 @@ ac_compiler_gnu=$ac_cv_c_compiler_gnu
+
+
+
+-for ac_header in sys/capability.h
+-do :
+- ac_fn_c_check_header_mongrel "$LINENO" "sys/capability.h" "ac_cv_header_sys_capability_h" "$ac_includes_default"
+-if test "x$ac_cv_header_sys_capability_h" = xyes; then :
+- cat >>confdefs.h <<_ACEOF
+-#define HAVE_SYS_CAPABILITY_H 1
+-_ACEOF
+-
+-else
+- as_fn_error $? "*** POSIX caps headers not found" "$LINENO" 5
+-fi
+-
+-done
+-
+-
+-# Check whether --enable-man was given.
+-if test "${enable_man+set}" = set; then :
+- enableval=$enable_man;
+-else
+- enable_man=maybe
+-fi
+-
+-
+-if test "$enable_man" != no; then :
+-
+- # Extract the first word of "xsltproc", so it can be a program name with args.
+-set dummy xsltproc; ac_word=$2
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
+-$as_echo_n "checking for $ac_word... " >&6; }
+-if ${ac_cv_path_XSLTPROC+:} false; then :
+- $as_echo_n "(cached) " >&6
+-else
+- case $XSLTPROC in
+- [\\/]* | ?:[\\/]*)
+- ac_cv_path_XSLTPROC="$XSLTPROC" # Let the user override the test with a path.
+- ;;
+- *)
+- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+-for as_dir in $PATH
+-do
+- IFS=$as_save_IFS
+- test -z "$as_dir" && as_dir=.
+- for ac_exec_ext in '' $ac_executable_extensions; do
+- if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+- ac_cv_path_XSLTPROC="$as_dir/$ac_word$ac_exec_ext"
+- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+- break 2
+- fi
+-done
+- done
+-IFS=$as_save_IFS
+-
+- ;;
+-esac
+-fi
+-XSLTPROC=$ac_cv_path_XSLTPROC
+-if test -n "$XSLTPROC"; then
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $XSLTPROC" >&5
+-$as_echo "$XSLTPROC" >&6; }
+-else
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+-$as_echo "no" >&6; }
+-fi
+-
+-
+- if test -z "$XSLTPROC"; then :
+-
+- if test "$enable_man" = yes; then :
+-
+- as_fn_error $? "xsltproc is required for --enable-man" "$LINENO" 5
+-
+-fi
+- enable_man=no
+-
+-else
+-
+- enable_man=yes
+-
+-fi
+-
+-fi
+- if test "$enable_man" != no; then
+- ENABLE_MAN_TRUE=
+- ENABLE_MAN_FALSE='#'
+-else
+- ENABLE_MAN_TRUE='#'
+- ENABLE_MAN_FALSE=
+-fi
+-
+-
+-
+-# Check whether --with-bash-completion-dir was given.
+-if test "${with_bash_completion_dir+set}" = set; then :
+- withval=$with_bash_completion_dir;
+-else
+- with_bash_completion_dir=yes
+-fi
+-
+-
+-if test "x$with_bash_completion_dir" = "xyes"; then
+-
+
+
+
+@@ -5445,6 +5344,107 @@ $as_echo "no" >&6; }
+ fi
+ fi
+
++for ac_header in sys/capability.h
++do :
++ ac_fn_c_check_header_mongrel "$LINENO" "sys/capability.h" "ac_cv_header_sys_capability_h" "$ac_includes_default"
++if test "x$ac_cv_header_sys_capability_h" = xyes; then :
++ cat >>confdefs.h <<_ACEOF
++#define HAVE_SYS_CAPABILITY_H 1
++_ACEOF
++
++else
++ as_fn_error $? "*** POSIX caps headers not found" "$LINENO" 5
++fi
++
++done
++
++
++# Check whether --enable-man was given.
++if test "${enable_man+set}" = set; then :
++ enableval=$enable_man;
++else
++ enable_man=maybe
++fi
++
++
++if test "$enable_man" != no; then :
++
++ # Extract the first word of "xsltproc", so it can be a program name with args.
++set dummy xsltproc; ac_word=$2
++{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
++$as_echo_n "checking for $ac_word... " >&6; }
++if ${ac_cv_path_XSLTPROC+:} false; then :
++ $as_echo_n "(cached) " >&6
++else
++ case $XSLTPROC in
++ [\\/]* | ?:[\\/]*)
++ ac_cv_path_XSLTPROC="$XSLTPROC" # Let the user override the test with a path.
++ ;;
++ *)
++ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
++for as_dir in $PATH
++do
++ IFS=$as_save_IFS
++ test -z "$as_dir" && as_dir=.
++ for ac_exec_ext in '' $ac_executable_extensions; do
++ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
++ ac_cv_path_XSLTPROC="$as_dir/$ac_word$ac_exec_ext"
++ $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
++ break 2
++ fi
++done
++ done
++IFS=$as_save_IFS
++
++ ;;
++esac
++fi
++XSLTPROC=$ac_cv_path_XSLTPROC
++if test -n "$XSLTPROC"; then
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $XSLTPROC" >&5
++$as_echo "$XSLTPROC" >&6; }
++else
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
++$as_echo "no" >&6; }
++fi
++
++
++ if test -z "$XSLTPROC"; then :
++
++ if test "$enable_man" = yes; then :
++
++ as_fn_error $? "xsltproc is required for --enable-man" "$LINENO" 5
++
++fi
++ enable_man=no
++
++else
++
++ enable_man=yes
++
++fi
++
++fi
++ if test "$enable_man" != no; then
++ ENABLE_MAN_TRUE=
++ ENABLE_MAN_FALSE='#'
++else
++ ENABLE_MAN_TRUE='#'
++ ENABLE_MAN_FALSE=
++fi
++
++
++
++# Check whether --with-bash-completion-dir was given.
++if test "${with_bash_completion_dir+set}" = set; then :
++ withval=$with_bash_completion_dir;
++else
++ with_bash_completion_dir=yes
++fi
++
++
++if test "x$with_bash_completion_dir" = "xyes"; then
++
+ pkg_failed=no
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for BASH_COMPLETION" >&5
+ $as_echo_n "checking for BASH_COMPLETION... " >&6; }