aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-12-31 20:06:53 +0000
committerMike Frysinger <vapier@gentoo.org>2009-12-31 20:06:53 +0000
commit93f5da47615def6e53e0760f48f394a0a03f82de (patch)
tree11239dde4628e4afb2da4bf2cf86a66e63fefb65
parentnetstat: fix %*s handling -- the field takes an int, not a size_t (diff)
downloadnet-tools-93f5da47615def6e53e0760f48f394a0a03f82de.tar.gz
net-tools-93f5da47615def6e53e0760f48f394a0a03f82de.tar.bz2
net-tools-93f5da47615def6e53e0760f48f394a0a03f82de.zip
fix parallel build problems with the lib/ subdir and multiple targets that descend into it
-rw-r--r--Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index f42a826..ad961ef 100644
--- a/Makefile
+++ b/Makefile
@@ -179,8 +179,9 @@ libdir: version.h
i18ndir:
@$(MAKE) -C po
-subdirs:
- @for i in $(SUBDIRS); do $(MAKE) -C $$i || exit $$? ; done
+# use libdir target for lib/ to avoid parallel build issues
+subdirs: libdir
+ @for i in $(SUBDIRS:$(NET_LIB_PATH)/=); do $(MAKE) -C $$i || exit $$? ; done
ifconfig: $(NET_LIB) ifconfig.o
$(CC) $(LDFLAGS) -o ifconfig ifconfig.o $(NLIB) $(RESLIB)