aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gmail.com>2017-12-03 20:34:23 -0500
committerTim Harder <radhermit@gmail.com>2017-12-03 20:34:23 -0500
commite9843a27f2ebe95a6e8faf897745cbfc18d0c9e9 (patch)
tree3302d38b91294ff21afa8a5efe97696142065720 /tox.ini
parentpkgcheck: drop unnecessary repo check (diff)
downloadpkgcheck-e9843a27f2ebe95a6e8faf897745cbfc18d0c9e9.tar.gz
pkgcheck-e9843a27f2ebe95a6e8faf897745cbfc18d0c9e9.tar.bz2
pkgcheck-e9843a27f2ebe95a6e8faf897745cbfc18d0c9e9.zip
tox: coverage-report: generate html files and ignore errors
Mutiple runs of coverage combine currently cause errors.
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini10
1 files changed, 6 insertions, 4 deletions
diff --git a/tox.ini b/tox.ini
index 60fa5a8a..e4c71978 100644
--- a/tox.ini
+++ b/tox.ini
@@ -11,8 +11,10 @@ commands =
[testenv:coverage-report]
skip_install = true
deps = coverage
+ignore_errors = true
commands =
coverage combine
+ coverage html
coverage report
# build docs
@@ -27,11 +29,11 @@ commands =
[testenv:dist]
skip_install = true
deps =
- -rrequirements/docs.txt
- -rrequirements/wheel.txt
+ -rrequirements/docs.txt
+ -rrequirements/wheel.txt
commands =
- python setup.py sdist
- python setup.py bdist_wheel
+ python setup.py sdist
+ python setup.py bdist_wheel
# test against snakeoil/pkgcore git
[testenv:dev]