summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-03 22:37:38 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-03 22:37:38 +0200
commita6de17b0ef3ce6dc7194749cd1d45c46d1e4d3a0 (patch)
tree5ef3412a603670c6fe58e5d2708929be944d94de
parentebuild.eclass: Calculate recursive @PROVIDES in initializer (diff)
downloadpkgcore-0.12.7.tar.gz
pkgcore-0.12.7.tar.bz2
pkgcore-0.12.7.zip
ebuild.eclass: remove indirect_inherits backwards compatv0.12.7
-rw-r--r--NEWS.rst3
-rw-r--r--src/pkgcore/ebuild/eclass.py3
2 files changed, 3 insertions, 3 deletions
diff --git a/NEWS.rst b/NEWS.rst
index 4ff7d5a0..ca78d0ae 100644
--- a/NEWS.rst
+++ b/NEWS.rst
@@ -9,6 +9,9 @@ pkgcore 0.12.7 (2021-09-03)
- pkgcore.ebuild.eclass: calculate recursive @PROVIDES in initializer
to include them in pkgcheck's eclass cache.
+- pkgcore.ebuild.eclass: remove 'indirect_eclasses' backwards
+ compatibility attribute.
+
---------------------------
pkgcore 0.12.6 (2021-09-02)
---------------------------
diff --git a/src/pkgcore/ebuild/eclass.py b/src/pkgcore/ebuild/eclass.py
index fdbd9dd2..cfb8088c 100644
--- a/src/pkgcore/ebuild/eclass.py
+++ b/src/pkgcore/ebuild/eclass.py
@@ -645,6 +645,3 @@ class EclassDoc(AttrDict):
"""Convert eclassdoc object to an HTML 5 document."""
from docutils.writers import html5_polyglot
return self._to_docutils(html5_polyglot.Writer())
-
- # backwards compatibility cruft, remove on next API breaker
- indirect_eclasses = klass.alias_attr('raw_provides')