summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index a9e029f..1904238 100644
--- a/Makefile
+++ b/Makefile
@@ -19,14 +19,19 @@ pms.html: $(SOURCEFILES) pms.bbl
@# need to do it twice to make the big env var table work
mk4ht xhlatex pms
mk4ht xhlatex pms
+ @# some www servers ignore meta tags, resulting in a wrong charset.
+ @# therefore recode the very few non-ascii characters
+ recode -d l1..h3 pms.html
@# work around irregularity in how links to longtables are
@# formatted in the List of Tables
LC_ALL=C sed -i -e '/<span class="lotToc" >&#x00A0;/{N;N;s/\(&#x00A0;<a \nhref="[^"]\+">\)\([0-9A-Z.]\+\)[ \n]/\2\1/}' pms.html
+ @# fix xhtml syntax in longtable captions
+ LC_ALL=C sed -i -e 's%</td>\( *<div class="multicolumn"\)%\1%;tx;b;:x;s%</tr>%</td>&%;t;n;bx' pms.html
@# indent algorithms properly, and avoid adding extra vertical
@# space in Konqueror
LC_ALL=C sed -i -e 's/span style="width:/span style="display:-moz-inline-box;display:inline-block;height:1px;width:/' pms.html
@# align algorithm line numbers properly
- LC_ALL=C sed -i -e '/<span class="ALCitem">/{N;s/\n\(class="[^"]\+">\)\([0-9]:\)<\/span>/\1\&#x2007;\2/}' pms.html
+ LC_ALL=C sed -i -e '/<span class="ALCitem">/{N;s/\n\(class="[^"]\+">\)\([0-9]:<\/span>\)/\1\&#x2007;\2/}' pms.html
pms.bbl: pms.bib pms.tex vc.tex eapi-cheatsheet.pdf
latex pms