summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/postgresql-client/postgresql-client-7.3.21.ebuild')
-rw-r--r--dev-db/postgresql-client/postgresql-client-7.3.21.ebuild88
1 files changed, 88 insertions, 0 deletions
diff --git a/dev-db/postgresql-client/postgresql-client-7.3.21.ebuild b/dev-db/postgresql-client/postgresql-client-7.3.21.ebuild
new file mode 100644
index 0000000..b938c6b
--- /dev/null
+++ b/dev-db/postgresql-client/postgresql-client-7.3.21.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="none"
+
+inherit eutils gnuconfig multilib toolchain-funcs versionator autotools
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+
+DESCRIPTION="PostgreSQL client applications"
+HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
+LICENSE="POSTGRESQL"
+SLOT="$(get_version_component_range 1-2)"
+# find . -name \*.po | xargs -n 1 basename | cut -d. -f1|sort|uniq|sed 's/^/linguas_/'
+IUSE_LINGUAS="
+ linguas_cs linguas_de linguas_es linguas_fr linguas_hr linguas_hu
+ linguas_pt_BR linguas_ru linguas_sv linguas_tr linguas_zh_CN
+ linguas_zh_TW"
+IUSE="doc nls ${IUSE_LINGUAS}"
+
+wanted_languages() {
+ for u in ${IUSE_LINGUAS} ; do
+ use $u && echo ${u#linguas_}
+ done
+}
+
+DEPEND="~dev-db/postgresql-libs-${PV}"
+RDEPEND="${DEPEND}"
+PDEPEND="doc? ( ~dev-db/postgresql-docs-${PV} )"
+
+S="${WORKDIR}/postgresql-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/postgresql-${PV}-autoconf.patch"
+ epatch "${FILESDIR}/postgresql-${SLOT}-client.patch"
+
+ # to avoid collision - it only should be installed by server
+ rm "${S}/src/backend/nls.mk"
+
+ eautoconf
+}
+
+src_compile() {
+ # TODO: test if PPC really cannot work with other CFLAGS settings
+ # use ppc && CFLAGS="-pipe -fsigned-char"
+
+ # eval is needed to get along with pg_config quotation of space-rich entities.
+ eval econf "$(/usr/$(get_libdir)/postgresql-${SLOT}/bin/pg_config --configure)" \
+ "$(built_with_use ~dev-db/postgresql-libs-${PV} nls && use_enable nls nls "$(wanted_languages)")" \
+ || die "configure failed"
+
+ for bd in . contrib ; do
+ PATH="/usr/lib/postgresql-${SLOT}/bin:${PATH}" \
+ emake -C $bd LD="$(tc-getLD) $(get_abi_LDFLAGS)" \
+ docdir=/usr/share/doc/${PF} SLOT=${SLOT} || die "emake in $bd failed"
+ done
+}
+
+src_install() {
+
+ for bd in . contrib ; do
+ PATH="/usr/lib/postgresql-${SLOT}/bin:${PATH}" \
+ emake -C $bd install DESTDIR="${D}" \
+ docdir=/usr/share/doc/${PF} SLOT=${SLOT} || die "emake install in $bd failed"
+ done
+
+ rm "${D}/usr/share/postgresql-${SLOT}/man/man1"/{initdb,ipcclean,pg_config,pg_controldata,pg_ctl,pg_resetxlog,pg_restore,postgres,postmaster,initlocation,ecpg}.1
+
+ dodoc README HISTORY doc/{README.*,TODO,bug.template}
+
+ dodir /usr/lib/eselect-postgresql/slots/${SLOT}
+ echo "postgres_ebuilds=\"\${postgres_ebuilds} ${PF}\"" >${D}/usr/lib/eselect-postgresql/slots/${SLOT}/client
+}
+
+pkg_postinst() {
+ eselect postgresql update
+ [[ "$(eselect postgresql show)" = "(none)" ]] && eselect postgresql set ${SLOT}
+}
+
+pkg_postrm() {
+ eselect postgresql update
+}