summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/postgresql-server/postgresql-server-7.4.19.ebuild')
-rw-r--r--dev-db/postgresql-server/postgresql-server-7.4.19.ebuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/dev-db/postgresql-server/postgresql-server-7.4.19.ebuild b/dev-db/postgresql-server/postgresql-server-7.4.19.ebuild
index dfd89e5..c1668c8 100644
--- a/dev-db/postgresql-server/postgresql-server-7.4.19.ebuild
+++ b/dev-db/postgresql-server/postgresql-server-7.4.19.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI="1"
+
WANT_AUTOCONF="latest"
WANT_AUTOMAKE="none"
inherit eutils gnuconfig multilib toolchain-funcs versionator autotools
@@ -13,7 +15,6 @@ HOMEPAGE="http://www.postgresql.org/"
SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
LICENSE="POSTGRESQL"
SLOT="$(get_version_component_range 1-2)"
-# find . -name \*.po | xargs -n 1 basename | cut -d. -f1|sort|uniq|sed 's/^/linguas_/'
IUSE_LINGUAS="
linguas_cs linguas_de linguas_es linguas_fr linguas_hr linguas_hu
linguas_it linguas_nb linguas_pt_BR linguas_ru linguas_sl linguas_sv
@@ -26,7 +27,7 @@ wanted_languages() {
done
}
-RDEPEND="~dev-db/postgresql-libs-${PV}
+RDEPEND="~dev-db/postgresql-base-${PV}:${SLOT}
perl? ( >=dev-lang/perl-5.6.1-r2 )
python? ( >=dev-lang/python-2.2 dev-python/egenix-mx-base )
selinux? ( sec-policy/selinux-postgresql )
@@ -34,8 +35,8 @@ RDEPEND="~dev-db/postgresql-libs-${PV}
xml? ( dev-libs/libxml2 dev-libs/libxslt )"
DEPEND="${RDEPEND}
xml? ( dev-util/pkgconfig )
- test? ( ~dev-db/postgresql-client-${PV} )"
-PDEPEND="doc? ( ~dev-db/postgresql-docs-${PV} )"
+ test? ( ~dev-db/postgresql-base-${PV}:${SLOT} )"
+PDEPEND="doc? ( dev-db/postgresql-docs:${SLOT} )"
[[ -r /etc/conf.d/postgresql-${SLOT} ]] && source /etc/conf.d/postgresql-${SLOT}
[[ -z "${PGDATA}" ]] && PGDATA="/var/lib/postgresql/${SLOT}/data"
@@ -197,10 +198,7 @@ src_test() {
PATH="/usr/lib/postgresql-${SLOT}/bin:${PATH}" \
emake -j1 check \
PGXS=$(/usr/$(get_libdir)/postgresql-${SLOT}/bin/pg_config --pgxs) \
- NO_PGXS=0 USE_PGXS=1 SLOT=${SLOT} || {
- hasq test ${FEATURES} && die "Make check failed. See above for details."
- hasq test ${FEATURES} || eerror "Make check failed. See above for details."
- }
+ NO_PGXS=0 USE_PGXS=1 SLOT=${SLOT} || die "Make check failed. See above for details."
einfo "Yes, there are other tests which could be run."
einfo "... and no, we don't plan to add/support them."