aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2024-04-21 20:21:07 +0300
committerJimi Huotari <chiitoo@gentoo.org>2024-04-21 22:49:28 +0300
commit4cee13aef9be956a5bf4858dd8e0e34f4365f0f4 (patch)
treee9bb0494df84086fee58de854f634e24e27b764b
parentlxqt-base/lxqt-qtplugin: add 2.0.0 (diff)
downloadqt-4cee13aef9be956a5bf4858dd8e0e34f4365f0f4.tar.gz
qt-4cee13aef9be956a5bf4858dd8e0e34f4365f0f4.tar.bz2
qt-4cee13aef9be956a5bf4858dd8e0e34f4365f0f4.zip
lxqt-base/lxqt-runner: add 2.0.0
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
-rw-r--r--lxqt-base/lxqt-runner/Manifest1
-rw-r--r--lxqt-base/lxqt-runner/lxqt-runner-2.0.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-runner/Manifest b/lxqt-base/lxqt-runner/Manifest
new file mode 100644
index 00000000..aa60fd99
--- /dev/null
+++ b/lxqt-base/lxqt-runner/Manifest
@@ -0,0 +1 @@
+DIST lxqt-runner-2.0.0.tar.xz 226344 BLAKE2B 3b831d1d1b0226e1785d4ee4fc93055cf01426335001c432cfc099f75c14421f467fa761648e77d826dfd6b36c9867779b88e38d971fe78846b102bcb7c945d1 SHA512 4c9ff79a0a4b7167023bd5447c83692be2e4e79ae48b6069deadae8ab4e5d6d73e6439169ffce87fc8f6000e65ed354fffb58188e9ba4f762b177b1c85c284c5
diff --git a/lxqt-base/lxqt-runner/lxqt-runner-2.0.0.ebuild b/lxqt-base/lxqt-runner/lxqt-runner-2.0.0.ebuild
new file mode 100644
index 00000000..df4effbd
--- /dev/null
+++ b/lxqt-base/lxqt-runner/lxqt-runner-2.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt quick launcher"
+HOMEPAGE="https://lxqt-project.org/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/qttools-6.6:6[linguist]
+ >=dev-util/lxqt-build-tools-2.0.0
+ virtual/pkgconfig
+"
+DEPEND="
+ >=dev-cpp/muParser-2.2.3
+ >=dev-libs/libqtxdg-4.0.0
+ >=dev-qt/qtbase-6.6:6[dbus,gui,widgets,xml]
+ kde-frameworks/kwindowsystem:6
+ >=kde-plasma/layer-shell-qt-6.0:6
+ =lxqt-base/liblxqt-${MY_PV}*:=
+ =lxqt-base/lxqt-globalkeys-${MY_PV}*
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ cmake_src_install
+ doman man/*.1
+}